summaryrefslogtreecommitdiff
path: root/x11-libs/gtkdatabox/gtkdatabox-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gtkdatabox/gtkdatabox-1.0.0-r1.ebuild')
-rw-r--r--x11-libs/gtkdatabox/gtkdatabox-1.0.0-r1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/x11-libs/gtkdatabox/gtkdatabox-1.0.0-r1.ebuild b/x11-libs/gtkdatabox/gtkdatabox-1.0.0-r1.ebuild
index 6e111b68cb2c..942e352d45ec 100644
--- a/x11-libs/gtkdatabox/gtkdatabox-1.0.0-r1.ebuild
+++ b/x11-libs/gtkdatabox/gtkdatabox-1.0.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit xdg-utils
+inherit autotools xdg-utils
DESCRIPTION="Gtk+ Widgets for live display of large amounts of fluctuating numerical data"
HOMEPAGE="https://sourceforge.net/projects/gtkdatabox/"
@@ -26,16 +26,19 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-slibtool.patch
+)
+
src_prepare() {
default
# Remove -D.*DISABLE_DEPRECATED cflags
find . -iname 'Makefile.am' -exec \
sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
- # Do Makefile.in after Makefile.am to avoid automake maintainer-mode
- find . -iname 'Makefile.in' -exec \
- sed -e '/-D[A-Z_]*DISABLE_DEPRECATED/d' -i {} + || die
- sed -e '/SUBDIRS/{s: examples::;}' -i Makefile.am -i Makefile.in || die
+ sed -e '/SUBDIRS/{s: examples::;}' -i Makefile.am || die
+
+ eautoreconf
}
src_configure() {