summaryrefslogtreecommitdiff
path: root/x11-plugins/wmsystemtray
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmsystemtray')
-rw-r--r--x11-plugins/wmsystemtray/Manifest3
-rw-r--r--x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch11
-rw-r--r--x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild10
3 files changed, 22 insertions, 2 deletions
diff --git a/x11-plugins/wmsystemtray/Manifest b/x11-plugins/wmsystemtray/Manifest
index 8f196dcb94dc..4ac008445309 100644
--- a/x11-plugins/wmsystemtray/Manifest
+++ b/x11-plugins/wmsystemtray/Manifest
@@ -1,3 +1,4 @@
+AUX wmsystemtray-1.4-ar.patch 336 BLAKE2B 3e3c475ecdad093c205fcf6920030db16893943604c2b9f60323e0fb06074cfe37624c640bedce98119321d31478e14c5a0fafc43e72eb0f7fa9ae702da9e2ba SHA512 dc5f3aae1c2bcf2ddb27f4daade36f25949ca9804be5ccd9842fb3ea2fea968a41204ce03bea0342f691c85a65f7be94f51fce169c64f7034986f0b915bc0e48
DIST wmsystemtray-1.4.tar.gz 131973 BLAKE2B c9927c39006b665163826ff3d937042df1a3d0ea4cf9045767ff511499151f6b525a9e9b37ca62955e61853f48e7b0148cbf8b5a9e4e130c81bc9af35df99150 SHA512 16620f222dc16d709e89d5011f699c9f96b6e4bf6014eec628574b84434b2e828ba12c92b5a598d1b9037dd16cbff2cc45f7ecb6533777c8a64bf435ea0c549c
-EBUILD wmsystemtray-1.4-r2.ebuild 472 BLAKE2B 5662522dda216b035ca1eea3771ccff289dae953d8905b6498960d7fe9833063923da629c82eb114dc56434cbbaa8d1bdbe9fa8a5b5b2b54b253b299ff95f902 SHA512 2a84eccc5f19e69c68b8f215683b5f4fc25dc2c83548d0d02f9883b9b9f437d6b6619cea679496f29e60f855822639db3b38b986ffc8ab5fff7812dedf612b60
+EBUILD wmsystemtray-1.4-r2.ebuild 572 BLAKE2B 50f4d60bbfa45a0aacb515c2fabd304003af4aa165b922ebd51d618acd20829c9617219d23eb91ba9bce83dfdd0618c4d4f05feca1d43b06db69200f9e961cc2 SHA512 f5acd18f80f0598dc495081c38ce5e9caec26d49c88af2a2db30a5618072ee4b6b38c0edd2a7e7f353fa941473a13673eadac62db2a10aa8281b32e1c3adff62
MISC metadata.xml 637 BLAKE2B 1e312f06da98323331726f3267f95744966864c4b676ebf8db41820a395167d93fc3f07610fad8688d10a13f8de8cc2f4294d5a26f134147abde58c8376564db SHA512 4889008c74a04fd6b13b19f9f31bdf9715c5962de4985d961731fcb2e502276306edae900cb2c5849c6cd6c7d9decb0579bd795943914750328189a7bc615548
diff --git a/x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch b/x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch
new file mode 100644
index 000000000000..785893a989fd
--- /dev/null
+++ b/x11-plugins/wmsystemtray/files/wmsystemtray-1.4-ar.patch
@@ -0,0 +1,11 @@
+diff -Naur wmsystemtray-1.4.orig/configure.ac wmsystemtray-1.4/configure.ac
+--- wmsystemtray-1.4.orig/configure.ac 2014-02-23 03:14:09.000000000 +0100
++++ wmsystemtray-1.4/configure.ac 2021-01-03 00:23:12.004713692 +0100
+@@ -9,6 +9,7 @@
+ AC_SUBST(VERSION)
+
+ # Checks for programs.
++AM_PROG_AR
+ AC_PROG_AWK
+ AC_PROG_CC
+ AC_PROG_CC_STDC
diff --git a/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild b/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild
index 568d2c1936e0..47d0230996a8 100644
--- a/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild
+++ b/x11-plugins/wmsystemtray/wmsystemtray-1.4-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
DESCRIPTION="a system tray dockapp with the ability to display more than just four tray icons"
HOMEPAGE="https://sourceforge.net/projects/wmsystemtray/"
@@ -16,3 +17,10 @@ DEPEND="x11-libs/libXext
x11-libs/libXmu
x11-libs/libXpm"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ar.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}