summaryrefslogtreecommitdiff
path: root/x11-terms/aterm/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/aterm/files')
-rw-r--r--x11-terms/aterm/files/aterm-1.0.1-configure-clang16.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/aterm/files/aterm-1.0.1-configure-clang16.patch b/x11-terms/aterm/files/aterm-1.0.1-configure-clang16.patch
new file mode 100644
index 000000000000..9faf68837d4e
--- /dev/null
+++ b/x11-terms/aterm/files/aterm-1.0.1-configure-clang16.patch
@@ -0,0 +1,23 @@
+Add missing int tpye, and avoid calling the undeclared exit function.
+Implicit ints and function declarations are language features removed
+in C99 and are likely to become unsupported (by default) in future
+compilers.
+
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -615,12 +615,12 @@
+ [#define X_LOCALE 1
+ #include <X11/Xlocale.h>
+ #include <X11/Xlib.h>
+-main() {
++int main() {
+ char *p;
+ if ((p = XSetLocaleModifiers("@im=none")) != NULL && *p)
+-exit (XSupportsLocale() ? 0 : 1);
++return XSupportsLocale() ? 0 : 1;
+ else
+-exit (1);}
++return 1;}
+ ],rxvt_cv_func_xlocale=yes, rxvt_cv_func_xlocale=no,
+ AC_MSG_WARN([Define NO_XLOCALE in config.h manually]))])
+