From 54c42eb42df420f52e032fcba7727c326ef01094 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Sat, 5 Nov 2022 09:17:35 +0000
Subject: gentoo auto-resync : 05:11:2022 - 09:17:35

---
 app-arch/Manifest.gz          | Bin 16921 -> 17084 bytes
 app-arch/cfv/Manifest         |   3 +++
 app-arch/cfv/cfv-3.0.0.ebuild |  48 ++++++++++++++++++++++++++++++++++++++++++
 app-arch/cfv/metadata.xml     |  20 ++++++++++++++++++
 app-arch/gcab/Manifest        |   2 +-
 app-arch/gcab/gcab-1.5.ebuild |   2 +-
 6 files changed, 73 insertions(+), 2 deletions(-)
 create mode 100644 app-arch/cfv/Manifest
 create mode 100644 app-arch/cfv/cfv-3.0.0.ebuild
 create mode 100644 app-arch/cfv/metadata.xml

(limited to 'app-arch')

diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index 3aff5784c94e..973ad5d17c9c 100644
Binary files a/app-arch/Manifest.gz and b/app-arch/Manifest.gz differ
diff --git a/app-arch/cfv/Manifest b/app-arch/cfv/Manifest
new file mode 100644
index 000000000000..988b76e011e0
--- /dev/null
+++ b/app-arch/cfv/Manifest
@@ -0,0 +1,3 @@
+DIST cfv-3.0.0.gh.tar.gz 91600 BLAKE2B 5a0d53a2b75973967ef976ce55d5262f71af97a8d7c64e8ea94ed9d66fd12778e10321e82bdbc4b8037df3f1a9c9c817694a7cd5e60615fc903127df9057b04f SHA512 9a44bf20f0a4f48a93631353d0b0ab79ea15d19f1da5492296dd4bd4e6208d3f0d71e957165e31d07b5faa7fc75122f0ae5ddbd8d54b9c6b633c43695b362640
+EBUILD cfv-3.0.0.ebuild 1205 BLAKE2B b6d995ccb0fa445726d348eefe2ba36129b60b711f13767a9af2eaff68f2d65a765dce7c0b6008c2f7f05746896519712d3dbbe93092596280d21fd2d028adda SHA512 f912b0f4ad16fc28e84c0e76e3b01266d775697bad2c2486b4a9c8af3e0d59385c4cbb2545caae53dee3a3835c35d906e258307221172c51080e033342b7c401
+MISC metadata.xml 752 BLAKE2B ad109bc840ed5d4b581fa93ed023eb489b2e410d6cfef41756680ae64c6ffb2a1ee4e8a979909d7584844bb8639d26374c00840864ffe380f0446226ab45f63f SHA512 6803dc7d2b3d65cf1586d6d4153280f2f672aa4be914ab80bd693a64282102a3bc59ad213b39830b7421f1764f912920e96cd975cc1929d1878452c87f12ba88
diff --git a/app-arch/cfv/cfv-3.0.0.ebuild b/app-arch/cfv/cfv-3.0.0.ebuild
new file mode 100644
index 000000000000..5b940295d074
--- /dev/null
+++ b/app-arch/cfv/cfv-3.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# Tests fail with pypy3 as of PyPy 7.3.9 / Python 3.9.12
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Command-line File Verify - versatile file checksum creator and verifier"
+HOMEPAGE="https://github.com/cfv-project/cfv/"
+# Tests aren't included in PyPI tarballs
+SRC_URI="https://github.com/cfv-project/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+	test? (
+		app-arch/cksfv
+	)
+"
+
+python_prepare_all() {
+	# Remove upstream's attempt to install the man page
+	sed -i '/\sdata_files=/d' setup.py || die
+	distutils-r1_python_prepare_all
+}
+
+python_test() {
+	# In order to run integration tests in addition to unit tests, we can't
+	# just rely on pytest here, we need to use upstream's runner.
+	"${EPYTHON}" "test/test.py" || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+	distutils-r1_python_install_all
+	doman cfv.1
+}
+
+pkg_postinst() {
+	optfeature "the dimension column of JPEG Sheriff crc files" dev-python/pillow
+}
diff --git a/app-arch/cfv/metadata.xml b/app-arch/cfv/metadata.xml
new file mode 100644
index 000000000000..373591c9c7a7
--- /dev/null
+++ b/app-arch/cfv/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+	<maintainer type="person">
+		<email>sbraz@gentoo.org</email>
+		<name>Louis Sautier</name>
+	</maintainer>
+	<longdescription>
+		cfv is a utility to test and create a wide range of checksum
+		verification files. It currently supports testing and creating sfv,
+		sfvmd5, csv, csv2, csv4, md5, bsdmd5, sha1, sha224, sha256, sha384,
+		sha512, torrent and crc files. Test-only support is available for par,
+		par2.
+	</longdescription>
+	<upstream>
+		<remote-id type="pypi">cfv</remote-id>
+		<remote-id type="github">cfv-project/cfv</remote-id>
+		<bugs-to>https://github.com/cfv-project/cfv/issues</bugs-to>
+	</upstream>
+</pkgmetadata>
diff --git a/app-arch/gcab/Manifest b/app-arch/gcab/Manifest
index e5c8b69266d9..041b5b002ee5 100644
--- a/app-arch/gcab/Manifest
+++ b/app-arch/gcab/Manifest
@@ -2,5 +2,5 @@ AUX 1.5-meson-git-version-is-optional.patch 1143 BLAKE2B 55152a557ec7ee282ae22c9
 DIST gcab-1.4.tar.xz 78240 BLAKE2B 8b857c116fab636db93463cee7d6b809c3c7b2bdf3896b7b5b5b66ebf270b284b356710933ec17584143bcef5c1f5c555811dd05ea98399f327047476a33fc16 SHA512 66a2e0d0a5888c555153356ce808f602053e71b76af19794db7e3bbf9516fe791805068838b4e208698cd645ada7a08610ac95f846fa81e00a9b955016306299
 DIST gcab-1.5.tar.xz 81728 BLAKE2B ba1793a8374e2dac412ca2807343781013f5be8d79e444ef0a136fbf903dd9a47809b3dec4703ebd19d196a7046a0c8405ae8463c2f7338fdc5eaf979436e8e1 SHA512 2a9b7d2720abbb5527d478ac760898ae254d08b7aa929fbb21753296e5a07c51d62e134a3f8b1b21d9b557d4093505194e09823ddbaf58465d37b372f37534b7
 EBUILD gcab-1.4.ebuild 1123 BLAKE2B b8169f5333b10bb26ec27ce57bb3f471c96fa9678bd7ed58db34a18a938054373e07ad8d8e2e9f2b585c2acd054f337219cce083eda6d4516267dbf136767023 SHA512 70ad8b8ec248aebb03e3806e50db1b370a7040ebec8e16e481fd343591fe20f84a160b1a476acc185c9acd70f8c3de7e993d307a3f14cd793691651c49249ebd
-EBUILD gcab-1.5.ebuild 1203 BLAKE2B 9c045a7fbe745907a30b02b061ad4e2c4793fedc1dff32db73b899e4c4a6ca7858090fab8207cf71b823044e7498fe4839da8a343c14b57a8b1967ad44f84af4 SHA512 4e6b0d75d5682950d3b9cb0ff6223ac37d378b6d70fb251285eff834466670e79c53e60844ec5f039c759532223b5bb688cc6f19e5092ad754a57117ac575f62
+EBUILD gcab-1.5.ebuild 1202 BLAKE2B a22d8482845daeccdd396b9f36f7d8ab555ba358a58ef7f70d3697332d9601deb7e44097fa03f92c990d73670b82e1439cb72b74c75305a918a3447182812445 SHA512 0b431cd5940ba1194a7115d3ca79dc35ffa39eab8f87a39bc102b6e5c3e3ee1ef17fe65b13827bd94faf6b97314cbd5d8577cf9cfecfdf206261aa32093595b5
 MISC metadata.xml 345 BLAKE2B d32d83f8c7d6db7c4d0c22125c547f3e838fd8154b2aa80c230ecc9c64a5edc84814f50bbc159c5921fcd767eea8c2eb65e08217eb284094a6fe122ee5a1e34a SHA512 83301d336de47bf8ab99a9b50097981433220039e2769c4dfe4779a7c2309fa69e5613fa209470f19e21de17a40177757e6abaa73c58f4145f0ef7ef1f1af5d4
diff --git a/app-arch/gcab/gcab-1.5.ebuild b/app-arch/gcab/gcab-1.5.ebuild
index a71aaaa4847a..6eb8beb9a4d1 100644
--- a/app-arch/gcab/gcab-1.5.ebuild
+++ b/app-arch/gcab/gcab-1.5.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://wiki.gnome.org/msitools https://gitlab.gnome.org/GNOME/gcab"
 
 LICENSE="LGPL-2.1+"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
 
 IUSE="gtk-doc +introspection test vala"
 RESTRICT="!test? ( test )"
-- 
cgit v1.2.3