From 54654470d999265b5a0010be7190e8a9993b1840 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Thu, 11 May 2023 17:46:59 +0100
Subject: gentoo auto-resync : 11:05:2023 - 17:46:59

---
 app-emacs/plz/Manifest              |  4 ++++
 app-emacs/plz/files/50plz-gentoo.el |  1 +
 app-emacs/plz/metadata.xml          | 20 +++++++++++++++++++
 app-emacs/plz/plz-0.5.4.ebuild      | 38 +++++++++++++++++++++++++++++++++++++
 4 files changed, 63 insertions(+)
 create mode 100644 app-emacs/plz/Manifest
 create mode 100644 app-emacs/plz/files/50plz-gentoo.el
 create mode 100644 app-emacs/plz/metadata.xml
 create mode 100644 app-emacs/plz/plz-0.5.4.ebuild

(limited to 'app-emacs/plz')

diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
new file mode 100644
index 000000000000..bd082e2ef771
--- /dev/null
+++ b/app-emacs/plz/Manifest
@@ -0,0 +1,4 @@
+AUX 50plz-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST plz-0.5.4.tar.gz 101382 BLAKE2B cba7089ed3f6c6d616d6d8b506e9779c1fdc56b8c048010cb2e61f03d83669aa3475314936c9fc4b02d473484268a303495605e785840644bc3b9b92f50be090 SHA512 3a64a49efcf32191099abcd5dd5955b02ce3afa98ec3ecd79d4bfaadf52bc4a5602fda3aca4482e77e465e5d071400ae8200cf900e4f0ed931e93e1458303fa1
+EBUILD plz-0.5.4.ebuild 771 BLAKE2B f005a9daeea1c89120de92bbbc29267fafaf75c608b15aa6b4909aa92ec844e843946cceda38ed5d27b35c3236db7a72ad932b14039e0ffb38e5290d0fc3192a SHA512 7502192929cf47da9ff120c650f9183bfcd52bb2281e3eba02c06a71776393d355a9f2f1bbb18139ca70dac5b563d3c56c82c3c659a4f0762438bc375555fafa
+MISC metadata.xml 826 BLAKE2B 2c26aa08682b905ec5f450f20a4b77b2ee2108f172deeda1bb95ddb80d1a6d53a76b091350126171c2b9dfda6161ba61958bbbf53fa94f4dd883b1eccd9f6125 SHA512 b48b5766222e784021656410b1467bbcab2646133d3a4af58601ace46ff68ee87df2a156329b19b72b1f42f77ad8f00c2fceca1210f8aca0db864ed044ffb0d6
diff --git a/app-emacs/plz/files/50plz-gentoo.el b/app-emacs/plz/files/50plz-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/plz/files/50plz-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/plz/metadata.xml b/app-emacs/plz/metadata.xml
new file mode 100644
index 000000000000..312ec018bd3c
--- /dev/null
+++ b/app-emacs/plz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+  <maintainer type="project">
+    <email>gnu-emacs@gentoo.org</email>
+    <name>Gentoo GNU Emacs project</name>
+  </maintainer>
+  <longdescription>
+    plz is an HTTP library for Emacs. It uses curl as a backend, which avoids
+    some of the issues with using Emacs's built-in url library. It supports
+    both synchronous and asynchronous requests. Its API is intended to be
+    simple, natural, and expressive. Its code is intended to be simple and
+    well-organized. Every feature is tested against httpbin.
+  </longdescription>
+  <upstream>
+    <bugs-to>https://github.com/alphapapa/plz.el/issues/</bugs-to>
+    <remote-id type="github">alphapapa/plz.el</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/app-emacs/plz/plz-0.5.4.ebuild b/app-emacs/plz/plz-0.5.4.ebuild
new file mode 100644
index 000000000000..fc3776f2a6fa
--- /dev/null
+++ b/app-emacs/plz/plz-0.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+	SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+		-> ${P}.tar.gz"
+	S="${WORKDIR}"/plz.el-${PV}
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+	elisp_src_install
+
+	doinfo plz.info
+}
-- 
cgit v1.2.3