From 70e4bd5c8f26b1f2baeb5146a841273b2cb15179 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Tue, 30 May 2023 09:20:33 +0100
Subject: gentoo auto-resync : 30:05:2023 - 09:20:33

---
 app-office/Manifest.gz                       | Bin 7893 -> 7897 bytes
 app-office/calcurse/Manifest                 |   4 +-
 app-office/calcurse/calcurse-4.8.0-r1.ebuild |  56 +++++++++++++++++++++++++++
 app-office/calcurse/calcurse-4.8.0.ebuild    |  51 ------------------------
 app-office/calcurse/calcurse-4.8.1.ebuild    |  56 +++++++++++++++++++++++++++
 5 files changed, 115 insertions(+), 52 deletions(-)
 create mode 100644 app-office/calcurse/calcurse-4.8.0-r1.ebuild
 delete mode 100644 app-office/calcurse/calcurse-4.8.0.ebuild
 create mode 100644 app-office/calcurse/calcurse-4.8.1.ebuild

(limited to 'app-office')

diff --git a/app-office/Manifest.gz b/app-office/Manifest.gz
index 764958cb8ce1..311800ca978c 100644
Binary files a/app-office/Manifest.gz and b/app-office/Manifest.gz differ
diff --git a/app-office/calcurse/Manifest b/app-office/calcurse/Manifest
index 70d4ecddbe0d..9f57cb8276f5 100644
--- a/app-office/calcurse/Manifest
+++ b/app-office/calcurse/Manifest
@@ -1,3 +1,5 @@
 DIST calcurse-4.8.0.tar.gz 716234 BLAKE2B 3fc703626d5e17b78ff42c0ef4f554585efd8223c2bd9d8c2f7add681602dc585cf066ed7c55a040b2585ad07513b26a5297b3b41f4c94a043f61ad2ad9094c2 SHA512 ea156c4320abf97fdb5abc29ff1f9bc659a3cab0e571295ed04b42dd742c4c45a7d5958dc2d386fc0ee7bd733969a6275405d5cf10cd645c75cb97b6b9e571d6
-EBUILD calcurse-4.8.0.ebuild 972 BLAKE2B 7179b3a691afd62d6691c59f6e9747308fe302d405288bda8e87b348caa2d0a8ebaa2ce685ad7d5bd2be384de69d37887a246327000c309a1ca55b59eb8db99c SHA512 0ba375048772df3453b9e15e03915a955cd271453ad87f675430a12faaa62dcb5717aca566eafdfe15902ba362abd6a3b84597d7aac427e92f48dfcd43578c2a
+DIST calcurse-4.8.1.tar.gz 730787 BLAKE2B 0c34b85313c3414dffc08635f6f37feb0a1e0f6c03bcf3b71a6cc95ed8fb4430ab1339abce72850364251884d707acb6cbbed0143d930f8bb76310ca5951b779 SHA512 a0a0bcfceb28a4e363168711a3c2de8f6e94d7f12aa78ff40f157c247ea6a41646bd218a1defba2d128b131ed0ab71c4d417820a0af0adbaa215011b11f0a040
+EBUILD calcurse-4.8.0-r1.ebuild 1061 BLAKE2B b004d683f1e131fc8dda1956bde6b6821dd1a0312476b7aa46bbd773797dc500f25e94a62ab120386d3536bf3b0d86e85728e8927d041700fd55c95b27d4acb9 SHA512 d3c088aa8ed0dc78ea08e24f307b8c744a72d8daf62b37493737865831668fb356b519d0175c3c84a6b00c27ee018b79d27946981c4c4ae8b7cc00bb7c3f11fb
+EBUILD calcurse-4.8.1.ebuild 1065 BLAKE2B 6ca2b80f51b4278b4e2dae3dcbf21c0c7bcdcfd7deca55d4a2f3838a711ec8a772c0eae136343ca446feec76ed5f05af90aa1e6140f6cae39c0e48b197bd2bee SHA512 725822ff3cb7dfc49d81b10b116730c09164184670b1074b8307f36d719481ee019c551b0d19894583178174ae0565fddea8f10631f9d59a254fd36355fdfdd6
 MISC metadata.xml 876 BLAKE2B b99953f6a4226dddb885201957911e1df6105e5bcbb2f69bbf20d35ef275d4c2a59388534ff1fc960285b9df8e96a4c9ce49a1aba945eab275fb418ee764d98c SHA512 c02a99a6f9ceeb94eee3f58d285f97e3d31d1bfaab82c410b9b48d0c9462190e834df8e3a8d634f8474a3ff519f2189d01ab02d6c2383fad54a8f4e6bd19c229
diff --git a/app-office/calcurse/calcurse-4.8.0-r1.ebuild b/app-office/calcurse/calcurse-4.8.0-r1.ebuild
new file mode 100644
index 000000000000..4bdc06bd097d
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.8.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc ppc64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="caldav doc"
+
+RDEPEND="
+	sys-libs/ncurses:0=
+	sys-libs/timezone-data
+	${PYTHON_DEPS}
+	caldav? (
+		$(python_gen_cond_dep '
+			dev-python/httplib2[${PYTHON_USEDEP}]
+			dev-python/pyparsing[${PYTHON_USEDEP}]
+		')
+	)
+"
+
+DEPEND="
+	${RDEPEND}
+"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+	local myconf=(
+		$(use_enable doc docs)
+		--without-asciidoc # do not use AsciiDoc to regenerate docs
+	)
+	ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+src_compile() {
+	default
+	if use caldav; then
+		python_fix_shebang contrib/caldav/calcurse-caldav
+	fi
+}
+
+src_install() {
+	docompress -x /usr/share/doc # decompress text files
+	default
+}
diff --git a/app-office/calcurse/calcurse-4.8.0.ebuild b/app-office/calcurse/calcurse-4.8.0.ebuild
deleted file mode 100644
index a918b427a68f..000000000000
--- a/app-office/calcurse/calcurse-4.8.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit python-single-r1
-
-DESCRIPTION="A text-based calendar and scheduling application"
-HOMEPAGE="https://calcurse.org/"
-SRC_URI="https://calcurse.org/files/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc ppc64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-IUSE="caldav doc"
-
-RDEPEND="
-	sys-libs/ncurses:0=
-	${PYTHON_DEPS}
-	caldav? (
-		$(python_gen_cond_dep '
-			dev-python/httplib2[${PYTHON_USEDEP}]
-			dev-python/pyparsing[${PYTHON_USEDEP}]
-		')
-	)
-"
-
-DEPEND="
-	${RDEPEND}
-"
-
-src_configure() {
-	local myconf=(
-		$(use_enable doc docs)
-		--without-asciidoc # do not use AsciiDoc to regenerate docs
-	)
-	ECONF_SOURCE="${S}" econf "${myconf[@]}"
-}
-
-src_compile() {
-	default
-	python_fix_shebang contrib/caldav/calcurse-caldav
-}
-
-src_install() {
-	docompress -x /usr/share/doc # decompress text files
-	default
-}
diff --git a/app-office/calcurse/calcurse-4.8.1.ebuild b/app-office/calcurse/calcurse-4.8.1.ebuild
new file mode 100644
index 000000000000..3472aa9d4909
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="caldav doc"
+
+RDEPEND="
+	sys-libs/ncurses:0=
+	sys-libs/timezone-data
+	${PYTHON_DEPS}
+	caldav? (
+		$(python_gen_cond_dep '
+			dev-python/httplib2[${PYTHON_USEDEP}]
+			dev-python/pyparsing[${PYTHON_USEDEP}]
+		')
+	)
+"
+
+DEPEND="
+	${RDEPEND}
+"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+	local myconf=(
+		$(use_enable doc docs)
+		--without-asciidoc # do not use AsciiDoc to regenerate docs
+	)
+	ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+src_compile() {
+	default
+	if use caldav; then
+		python_fix_shebang contrib/caldav/calcurse-caldav
+	fi
+}
+
+src_install() {
+	docompress -x /usr/share/doc # decompress text files
+	default
+}
-- 
cgit v1.2.3