From 1f43daba2fbe6f53e67c63944941dc645657c5b3 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Thu, 11 Apr 2024 18:33:04 +0100
Subject: gentoo auto-resync : 11:04:2024 - 18:33:04

---
 gui-apps/foot/Manifest           |  2 ++
 gui-apps/foot/foot-1.17.1.ebuild | 75 ++++++++++++++++++++++++++++++++++++++++
 2 files changed, 77 insertions(+)
 create mode 100644 gui-apps/foot/foot-1.17.1.ebuild

(limited to 'gui-apps/foot')

diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index 74921e014ea1..56bebd5bfcab 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -1,5 +1,7 @@
 DIST foot-1.16.2_20240120.tar.gz 529312 BLAKE2B edb4f0449effbc441ef5f0bdb5a99369633510826b3a129ff9897135df02c7e81ceea45facf0ce20b8b97bd878947426006722b6468eaabd02046b78ab2d8775 SHA512 1cdace64a21f155b440b17ad0a4cdd9150b8f4f44afdc3ff92d1dddc4c222fb9353a74ec4416c90753c70372d9f0e6ef762d00d6de4190e226621dccfc82ee1d
 DIST foot-1.17.0.tar.gz 543481 BLAKE2B 4af1665450d7d09d80502b74aa7b5be0c063f3df93aa67c4b2d1da5e69a5148db856436ffbc5868af93980e92145912da6bfcf27a3e81bf953e0e094193f5955 SHA512 4d24575c94ac5429b21134a21dd8b03d232d36798345fac3102b8a58de2acd951f6c1b4527085456072c3a0816d3fcf60210ec2004d84484b26bba22f44fbd89
+DIST foot-1.17.1.tar.gz 546745 BLAKE2B 5cb0b6dd323ce3f67dfdb47e4f06169327c95b6c5c06495f0f6a743a409684a5181970e8ac0141a857b3784c0f6f0f0647ce7db19bd99f1a0c1a0c8d846700c1 SHA512 b77d8198c504a337484ace06bc931998a70a753869c099bcab13dba3df629fd219d6bc23f22157b202333b2d5876f6030d9eeae77f1735e6983ab1c96aa8ca23
 EBUILD foot-1.16.2.ebuild 1682 BLAKE2B 1feec892a07ab7551113006ebca020d57a841fce8da85cb66a16b748640345949ce831423b2f223778fab7b0307148b8a5e085dae4513b9d6b5029fab8fdf79a SHA512 6f3b46fb559c159d61e918223d4cae06e1b590692ba7042542015259b0b4b56d3d14efe04936bac8e07497f1e69ca40f3b82b3025cae9d10640d96c36120ab1d
 EBUILD foot-1.17.0.ebuild 1656 BLAKE2B 52ab20d3e694c665c18a111aa1d8cf84c1ce3e73d5c46a7de0f8a59f4662d54b2f493d4795fcc593d21f0d06a4824a57f706aa10a0f29b140924663b48f362ae SHA512 529c078a8a35fa051dc390eda25fcb470e141e338c1948609c83c3962494d15862f99932001ecdfa29cda2db594c79b4ba02a3b92d1e2d69ab139294ceaa3d49
+EBUILD foot-1.17.1.ebuild 1656 BLAKE2B 52ab20d3e694c665c18a111aa1d8cf84c1ce3e73d5c46a7de0f8a59f4662d54b2f493d4795fcc593d21f0d06a4824a57f706aa10a0f29b140924663b48f362ae SHA512 529c078a8a35fa051dc390eda25fcb470e141e338c1948609c83c3962494d15862f99932001ecdfa29cda2db594c79b4ba02a3b92d1e2d69ab139294ceaa3d49
 MISC metadata.xml 417 BLAKE2B 79751f755417450132e2d66f53ab5642452178da0f08b877572db0f1c3de3093c1047cd9e8e3d8b884745b54e1e7a60425e453e987193625e3be806cfe07023e SHA512 9392f93e37673f12fe5587fc4e4ea55014080b254e327532375212c7b2c43870cd5342b45afc170a60776ab747108ce70cf888096070c74f258fe6392ef23155
diff --git a/gui-apps/foot/foot-1.17.1.ebuild b/gui-apps/foot/foot-1.17.1.ebuild
new file mode 100644
index 000000000000..51e7d44c3c4c
--- /dev/null
+++ b/gui-apps/foot/foot-1.17.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg systemd
+
+DESCRIPTION="Fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+SRC_URI="
+	https://codeberg.org/dnkl/foot/releases/download/${PV}/${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE="+grapheme-clustering test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+	dev-libs/wayland
+	media-libs/fcft
+	media-libs/fontconfig
+	x11-libs/libxkbcommon
+	x11-libs/pixman
+	grapheme-clustering? (
+		dev-libs/libutf8proc:=
+		media-libs/fcft[harfbuzz]
+	)
+"
+DEPEND="
+	${COMMON_DEPEND}
+	>=dev-libs/tllist-1.1.0
+	>=dev-libs/wayland-protocols-1.32
+"
+RDEPEND="
+	${COMMON_DEPEND}
+	|| (
+		>=sys-libs/ncurses-6.3[-minimal]
+		~gui-apps/foot-terminfo-${PV}
+	)
+"
+BDEPEND="
+	app-text/scdoc
+	dev-util/wayland-scanner
+"
+
+src_prepare() {
+	default
+	# disable the systemd dep, we install the unit file manually
+	sed -i "s/systemd', required: false)$/', required: false)/" "${S}"/meson.build || die
+}
+
+src_configure() {
+	local emesonargs=(
+		$(meson_feature grapheme-clustering)
+		$(meson_use test tests)
+		-Dthemes=true
+		-Dime=true
+		-Dterminfo=disabled
+	)
+	meson_src_configure
+
+	sed 's|@bindir@|/usr/bin|g' "${S}"/foot-server.service.in > foot-server.service || die
+}
+
+src_install() {
+	local DOCS=( CHANGELOG.md README.md LICENSE )
+	meson_src_install
+
+	# foot unconditionally installs CHANGELOG.md, README.md and LICENSE.
+	# we handle this via DOCS and dodoc instead.
+	rm -r "${ED}/usr/share/doc/${PN}" || die
+	systemd_douserunit foot-server.service "${S}"/foot-server.socket
+}
-- 
cgit v1.2.3