From aa4954f71a3ba2293395a8cce2321a70c39c7554 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Fri, 24 May 2024 00:07:11 +0100
Subject: gentoo auto-resync : 24:05:2024 - 00:07:11

---
 gui-wm/sway/Manifest           |   4 +-
 gui-wm/sway/sway-1.9-r1.ebuild | 114 +++++++++++++++++++++++++++++++++++++++++
 gui-wm/sway/sway-1.9.ebuild    | 114 -----------------------------------------
 gui-wm/sway/sway-9999.ebuild   |   2 +-
 4 files changed, 117 insertions(+), 117 deletions(-)
 create mode 100644 gui-wm/sway/sway-1.9-r1.ebuild
 delete mode 100644 gui-wm/sway/sway-1.9.ebuild

(limited to 'gui-wm/sway')

diff --git a/gui-wm/sway/Manifest b/gui-wm/sway/Manifest
index 76d4017be40b..82f4afe4bf5f 100644
--- a/gui-wm/sway/Manifest
+++ b/gui-wm/sway/Manifest
@@ -1,5 +1,5 @@
 AUX sway-portals.conf 216 BLAKE2B d30b62bb142802e5067c2829d69faba87b07c8a36661f43473b0a107fd57d020b3dcc5e7a1967a1fca13b7a5e9140063b7285c44b766f67002213521d676b1ab SHA512 790741df028822bf4d83170dea57e1c63f7d7938cf31969e4cd347b0fc07330322b603c9ec0091b7a3f425132bed9dee6f261074cc273555120858beaaaf5da1
 DIST sway-1.9.tar.gz 5581281 BLAKE2B 11d90866e3d12a76880f41e006be5ae7f3a3b1e6cbeb2412d30b673be91be7f60523dcce2892579e1da76de1d0498e0669138aa953bf1f595b97123720812e06 SHA512 7ec0a29078eb7e0fb1b6af97613c263adec78ddb03a63cb75fb5e44c7241ed144687fd094ee2eb70f4397832ca9bdffc88bc32dee7683bf0e515417c7a05d4c4
-EBUILD sway-1.9.ebuild 2690 BLAKE2B 525da24f7b6a2cef34e8e9fdc88bf0d659a8cbe81938f57923fd830f42165e3f77db6f5ce01f4b40e59925cf71455ace91b544cdd00af6f0adb986c871a9c59b SHA512 504a560698dcdbb7402624bb9478d86f4082b16d72ab7d8c6093985129b16477078981a97aab2162462a35262d6f03cc005d419594afaa2490529417c2b44e0f
-EBUILD sway-9999.ebuild 2604 BLAKE2B 30b11f23111326ec38b54bb67b222b712cd9929b4a7fbb3b83ab69751358b21f89e38de0f49e4cee4cc2c6cecfeb05f2e19978cf34f35efa84d6034f5c79445b SHA512 458f99b52201846dfe23173066a85bf1f165861b63a888b42c4e2fb8e6cddf7b14e8b96f04b411f66a04a03ddb8875f7f6ac21afc3b5105c304e459596bcaf8b
+EBUILD sway-1.9-r1.ebuild 2675 BLAKE2B 24bebac0e03fb711ca35ef9f1573cbc6e93e328b44ecdc4c820d8eb1547f20ea282b7d47e80bbba1ac880ad4f47da30303aa8c9bca76e1ef40fdd0dcaccf13ff SHA512 2400edfa580ecce14f2fdc2e825557d682b21bbd5dadf609d10e0769b3dcb1007ba75aed3b6c311dc6ec8fada33ccd5720d84d2a640dafd3032b5a483fc85295
+EBUILD sway-9999.ebuild 2589 BLAKE2B 991b6e622b5e9bdeea4dd508e81966b49dad4b76aa03396664e81cafe67f91b77090c2c6281eb5c645082ed23615e14c86703114ec4d0670e8f241923d05f896 SHA512 449731888489840e692af395baa8ca4e1266de8cbe783c74edd05c259e73b9d26a3e377c06d8abe91fd29376dfcab714a4f0b83ad53068cec48a1b2cca219016
 MISC metadata.xml 1721 BLAKE2B 39795f8d7c4a736141417e267e2c4645f4f963107c47516747c7fbc1643ed2e9787812c5571369b795e3648d4801dff32c062bf2db6d80ce79735d1be65b8ac8 SHA512 458d2adb61ecb91cc9d589409c69bffa7dee51328a557567e66c21eeff7e23eadaf36a04ca9fae32aa9d6edf1e28fa1bcba62f3e185699a8c08785f84977bb88
diff --git a/gui-wm/sway/sway-1.9-r1.ebuild b/gui-wm/sway/sway-1.9-r1.ebuild
new file mode 100644
index 000000000000..d9a62c2120ec
--- /dev/null
+++ b/gui-wm/sway/sway-1.9-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps meson optfeature
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+	MY_PV=${PV/_rc/-rc}
+	SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv x86"
+	S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man +swaybar +swaynag tray wallpapers X"
+REQUIRED_USE="tray? ( swaybar )"
+
+DEPEND="
+	>=dev-libs/json-c-0.13:0=
+	>=dev-libs/libinput-1.21.0:0=
+	virtual/libudev
+	sys-auth/seatd:=
+	dev-libs/libpcre2
+	>=dev-libs/wayland-1.20.0
+	x11-libs/cairo
+	>=x11-libs/libxkbcommon-1.5.0:0=
+	x11-libs/pango
+	x11-libs/pixman
+	media-libs/libglvnd
+	swaybar? ( x11-libs/gdk-pixbuf:2 )
+	tray? ( || (
+		sys-apps/systemd
+		sys-auth/elogind
+		sys-libs/basu
+	) )
+	wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
+	X? (
+		x11-libs/libxcb:0=
+		x11-libs/xcb-util-wm
+	)
+"
+# x11-libs/xcb-util-wm needed for xcb-iccm
+if [[ ${PV} == 9999 ]]; then
+	DEPEND+="~gui-libs/wlroots-9999:=[X?]"
+else
+	DEPEND+="
+		>=gui-libs/wlroots-0.17:=[X?]
+		<gui-libs/wlroots-0.18:=[X?]
+	"
+fi
+RDEPEND="
+	x11-misc/xkeyboard-config
+	${DEPEND}
+"
+BDEPEND="
+	>=dev-libs/wayland-protocols-1.24
+	>=dev-build/meson-0.60.0
+	virtual/pkgconfig
+"
+if [[ ${PV} == 9999 ]]; then
+	BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+	BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
+fi
+
+FILECAPS=(
+	cap_sys_nice usr/bin/${PN} # bug 919298
+)
+
+src_configure() {
+	local emesonargs=(
+		$(meson_feature man man-pages)
+		$(meson_feature tray)
+		$(meson_feature X xwayland)
+		$(meson_feature swaybar gdk-pixbuf)
+		$(meson_use swaynag)
+		$(meson_use swaybar)
+		$(meson_use wallpapers default-wallpaper)
+		-Dfish-completions=true
+		-Dzsh-completions=true
+		-Dbash-completions=true
+	)
+
+	meson_src_configure
+}
+
+src_install() {
+	meson_src_install
+	insinto /usr/share/xdg-desktop-portal
+	doins "${FILESDIR}/sway-portals.conf"
+}
+
+pkg_postinst() {
+	fcaps_pkg_postinst
+
+	optfeature_header "There are several packages that may be useful with sway:"
+	optfeature "wallpaper utility" gui-apps/swaybg
+	optfeature "idle management utility" gui-apps/swayidle
+	optfeature "simple screen locker" gui-apps/swaylock
+	optfeature "lightweight notification daemon" gui-apps/mako
+	echo
+	einfo "For a list of additional addons and tools usable with sway please"
+	einfo "visit the official wiki at:"
+	einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+	einfo "Please note that some of them might not (yet) available on gentoo"
+}
diff --git a/gui-wm/sway/sway-1.9.ebuild b/gui-wm/sway/sway-1.9.ebuild
deleted file mode 100644
index 85c49a9b40ca..000000000000
--- a/gui-wm/sway/sway-1.9.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps meson optfeature
-
-DESCRIPTION="i3-compatible Wayland window manager"
-HOMEPAGE="https://swaywm.org"
-
-if [[ ${PV} == 9999 ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
-else
-	MY_PV=${PV/_rc/-rc}
-	SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-	KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv x86"
-	S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man +swaybar +swaynag tray wallpapers X"
-REQUIRED_USE="tray? ( swaybar )"
-
-DEPEND="
-	>=dev-libs/json-c-0.13:0=
-	>=dev-libs/libinput-1.21.0:0=
-	virtual/libudev
-	sys-auth/seatd:=
-	dev-libs/libpcre2
-	>=dev-libs/wayland-1.20.0
-	x11-libs/cairo
-	>=x11-libs/libxkbcommon-1.5.0:0=
-	x11-libs/pango
-	x11-libs/pixman
-	media-libs/mesa[gles2,libglvnd(+)]
-	swaybar? ( x11-libs/gdk-pixbuf:2 )
-	tray? ( || (
-		sys-apps/systemd
-		sys-auth/elogind
-		sys-libs/basu
-	) )
-	wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
-	X? (
-		x11-libs/libxcb:0=
-		x11-libs/xcb-util-wm
-	)
-"
-# x11-libs/xcb-util-wm needed for xcb-iccm
-if [[ ${PV} == 9999 ]]; then
-	DEPEND+="~gui-libs/wlroots-9999:=[X?]"
-else
-	DEPEND+="
-		>=gui-libs/wlroots-0.17:=[X?]
-		<gui-libs/wlroots-0.18:=[X?]
-	"
-fi
-RDEPEND="
-	x11-misc/xkeyboard-config
-	${DEPEND}
-"
-BDEPEND="
-	>=dev-libs/wayland-protocols-1.24
-	>=dev-build/meson-0.60.0
-	virtual/pkgconfig
-"
-if [[ ${PV} == 9999 ]]; then
-	BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
-	BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
-fi
-
-FILECAPS=(
-	cap_sys_nice usr/bin/${PN} # bug 919298
-)
-
-src_configure() {
-	local emesonargs=(
-		$(meson_feature man man-pages)
-		$(meson_feature tray)
-		$(meson_feature X xwayland)
-		$(meson_feature swaybar gdk-pixbuf)
-		$(meson_use swaynag)
-		$(meson_use swaybar)
-		$(meson_use wallpapers default-wallpaper)
-		-Dfish-completions=true
-		-Dzsh-completions=true
-		-Dbash-completions=true
-	)
-
-	meson_src_configure
-}
-
-src_install() {
-	meson_src_install
-	insinto /usr/share/xdg-desktop-portal
-	doins "${FILESDIR}/sway-portals.conf"
-}
-
-pkg_postinst() {
-	fcaps_pkg_postinst
-
-	optfeature_header "There are several packages that may be useful with sway:"
-	optfeature "wallpaper utility" gui-apps/swaybg
-	optfeature "idle management utility" gui-apps/swayidle
-	optfeature "simple screen locker" gui-apps/swaylock
-	optfeature "lightweight notification daemon" gui-apps/mako
-	echo
-	einfo "For a list of additional addons and tools usable with sway please"
-	einfo "visit the official wiki at:"
-	einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
-	einfo "Please note that some of them might not (yet) available on gentoo"
-}
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index a23327214abb..60561d8f0deb 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -34,7 +34,7 @@ DEPEND="
 	>=x11-libs/libxkbcommon-1.5.0:0=
 	x11-libs/pango
 	x11-libs/pixman
-	media-libs/mesa[gles2,libglvnd(+)]
+	media-libs/libglvnd
 	swaybar? ( x11-libs/gdk-pixbuf:2 )
 	tray? ( || (
 		sys-apps/systemd
-- 
cgit v1.2.3