From cdc1eda9c1ad611dd737415be2790c8f44812f1c Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Sun, 12 Nov 2023 04:31:34 +0000
Subject: gentoo auto-resync : 12:11:2023 - 04:31:34

---
 gui-wm/Manifest.gz                          | Bin 1211 -> 1210 bytes
 gui-wm/gamescope/Manifest                   |   2 +-
 gui-wm/gamescope/gamescope-3.13.0-r1.ebuild |  94 ++++++++++++++++++++
 gui-wm/gamescope/gamescope-3.13.0.ebuild    |  94 --------------------
 gui-wm/hyprland/Manifest                    |   2 +
 gui-wm/hyprland/hyprland-0.32.2.ebuild      | 130 ++++++++++++++++++++++++++++
 6 files changed, 227 insertions(+), 95 deletions(-)
 create mode 100644 gui-wm/gamescope/gamescope-3.13.0-r1.ebuild
 delete mode 100644 gui-wm/gamescope/gamescope-3.13.0.ebuild
 create mode 100644 gui-wm/hyprland/hyprland-0.32.2.ebuild

(limited to 'gui-wm')

diff --git a/gui-wm/Manifest.gz b/gui-wm/Manifest.gz
index 6c5f1760f07c..02c7689810f6 100644
Binary files a/gui-wm/Manifest.gz and b/gui-wm/Manifest.gz differ
diff --git a/gui-wm/gamescope/Manifest b/gui-wm/gamescope/Manifest
index 106e080b15c2..2439e2ab7aae 100644
--- a/gui-wm/gamescope/Manifest
+++ b/gui-wm/gamescope/Manifest
@@ -1,4 +1,4 @@
 DIST gamescope-3.13.0.tar.gz 475785 BLAKE2B aa17fcbb8df5092c486d6f7e5fcae3a991c59b8187fdd1aa3ac97598ebe3b07fb969d51854ff5617cde28deb62e8aaebc5bea0e11181ca66c80ce78efe7820f6 SHA512 45b20aab52adf6f3092afaf5454a11280e52c50672660679d7da7ab1fde73fd537d58a8f644fd737b7cf4d0c9fcf4a6d63fa15f35fc4beb6db1883d5c223eec0
 DIST reshade-9fdbea6892f9959fdc18095d035976c574b268b7.tar.gz 1543894 BLAKE2B 5e2b643ffbbda3ad078deb075a6fada1d0a560c6d865b7febee6a8eaade83ec90db3c5a8f4130d27b6dfaa8ee7b899edd214c23c947678eed28fb8e7165d9bd2 SHA512 4565d094e1c2d53d5073b4976874665d38dcf7ca86e982e569cc76923eaa9187fa32a4385fc577a3a867d2917596e6377e5a023a34bc2d389ff899d5b69764fb
-EBUILD gamescope-3.13.0.ebuild 2538 BLAKE2B f53b4fd61f64796df056ee7da2232c7e2c88993b0938af22562560b9fe1b52de21b82ed07999f71e4df447d29be82483c5598a8be8136119f582e7c9c560da57 SHA512 993d457a4ac4de8d4e815c02b55394360d4a22b45cf5237f3b1e79533cfb29cf27f1344772a1e724dd334cd304085921dc36689b905761372aca34b8a33a96bb
+EBUILD gamescope-3.13.0-r1.ebuild 2550 BLAKE2B 9cc802bd425222823734cfe51633fc41f94a1982a55ef88909b6461471090af2f2ee89cd88aa54bac41604ba4b7b4b5fcbc6bc853c069b35fb4b4aa7963d7f65 SHA512 e507dd11825050e96ff05de044fc838b6a3cf7092d0c945667fe2932ddc4db208642887d803c68be0a47b5c75026357e2927c6145489e2344d78e1fc5f74d22c
 MISC metadata.xml 489 BLAKE2B 6930da0ca2827741a902e064b3bca71266ac5c2e61d7cf6d566c37e971efd04b2fcd2381659e1d5babe6fd05dd4d06979c0d82b3ac5e2702bb5d3311ef30df79 SHA512 419f4a3f3dc7a940d0f157323b9afd116b4a4d2efc718eb5979d84677b770a606c532d0777dbed1b6598afa393894e5dc9982dbaf7e31c90a9e0b433938d4e55
diff --git a/gui-wm/gamescope/gamescope-3.13.0-r1.ebuild b/gui-wm/gamescope/gamescope-3.13.0-r1.ebuild
new file mode 100644
index 000000000000..15625aa4cf0f
--- /dev/null
+++ b/gui-wm/gamescope/gamescope-3.13.0-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps meson
+
+RESHADE_COMMIT="9fdbea6892f9959fdc18095d035976c574b268b7"
+MY_PV=$(ver_rs 3 -)
+MY_PV="${MY_PV//_/-}"
+
+DESCRIPTION="Efficient micro-compositor for running games"
+HOMEPAGE="https://github.com/ValveSoftware/gamescope"
+SRC_URI="https://github.com/ValveSoftware/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz
+	https://github.com/Joshua-Ashton/reshade/archive/${RESHADE_COMMIT}.tar.gz -> reshade-${RESHADE_COMMIT}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="pipewire +wsi-layer"
+
+RDEPEND="
+	=dev-libs/libliftoff-0.4*
+	>=dev-libs/wayland-1.21
+	>=dev-libs/wayland-protocols-1.17
+	=gui-libs/wlroots-0.16*[X,libinput(+)]
+	>=media-libs/libdisplay-info-0.1.1
+	media-libs/libsdl2[video,vulkan]
+	media-libs/vulkan-loader
+	sys-apps/hwdata
+	sys-libs/libcap
+	>=x11-libs/libdrm-2.4.109
+	x11-libs/libX11
+	x11-libs/libXcomposite
+	x11-libs/libXdamage
+	x11-libs/libXext
+	x11-libs/libXfixes
+	x11-libs/libxkbcommon
+	x11-libs/libXmu
+	x11-libs/libXrender
+	x11-libs/libXres
+	x11-libs/libXtst
+	x11-libs/libXxf86vm
+	pipewire? ( >=media-video/pipewire-0.3:= )
+	wsi-layer? ( x11-libs/libxcb )
+"
+DEPEND="
+	${RDEPEND}
+	dev-libs/stb
+	dev-util/vulkan-headers
+	media-libs/glm
+	dev-util/spirv-headers
+	wsi-layer? ( >=media-libs/vkroots-0_p20231108 )
+"
+BDEPEND="
+	dev-util/glslang
+	dev-util/wayland-scanner
+	virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+FILECAPS=(
+	cap_sys_nice usr/bin/${PN}
+)
+
+src_prepare() {
+	default
+
+	# Normally wraps stb with Meson. Upstream does not ship a pkg-config file so
+	# we don't install one. Work around this using symlinks.
+	mkdir subprojects/stb || die
+	ln -sn "${ESYSROOT}"/usr/include/stb/* "${S}"/subprojects/packagefiles/stb/* subprojects/stb/ || die
+
+	# ReShade is bundled as a git submodule, but it references an unofficial
+	# fork, so we cannot unbundle it. Symlink to its extracted sources.
+	rmdir src/reshade || die
+	ln -snfT ../../reshade-${RESHADE_COMMIT} src/reshade || die
+
+	# SPIRV-Headers is required by ReShade. It is bundled as a git submodule but
+	# not wrapped with Meson, so we can symlink to our system-wide headers.
+	mkdir thirdparty/SPIRV-Headers/include || die
+	ln -snf "${ESYSROOT}"/usr/include/spirv thirdparty/SPIRV-Headers/include/ || die
+}
+
+src_configure() {
+	local emesonargs=(
+		--force-fallback-for=
+		-Dbenchmark=disabled
+		-Denable_openvr_support=false
+		$(meson_feature pipewire)
+		$(meson_use wsi-layer enable_gamescope_wsi_layer)
+	)
+	meson_src_configure
+}
diff --git a/gui-wm/gamescope/gamescope-3.13.0.ebuild b/gui-wm/gamescope/gamescope-3.13.0.ebuild
deleted file mode 100644
index 652cf3eb3de7..000000000000
--- a/gui-wm/gamescope/gamescope-3.13.0.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps meson
-
-RESHADE_COMMIT="9fdbea6892f9959fdc18095d035976c574b268b7"
-MY_PV=$(ver_rs 3 -)
-MY_PV="${MY_PV//_/-}"
-
-DESCRIPTION="Efficient micro-compositor for running games"
-HOMEPAGE="https://github.com/ValveSoftware/gamescope"
-SRC_URI="https://github.com/ValveSoftware/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz
-	https://github.com/Joshua-Ashton/reshade/archive/${RESHADE_COMMIT}.tar.gz -> reshade-${RESHADE_COMMIT}.tar.gz"
-KEYWORDS="~amd64"
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="pipewire +wsi-layer"
-
-RDEPEND="
-	=dev-libs/libliftoff-0.4*
-	>=dev-libs/wayland-1.21
-	>=dev-libs/wayland-protocols-1.17
-	=gui-libs/wlroots-0.16*[X]
-	>=media-libs/libdisplay-info-0.1.1
-	media-libs/libsdl2[video,vulkan]
-	media-libs/vulkan-loader
-	sys-apps/hwdata
-	sys-libs/libcap
-	>=x11-libs/libdrm-2.4.109
-	x11-libs/libX11
-	x11-libs/libXcomposite
-	x11-libs/libXdamage
-	x11-libs/libXext
-	x11-libs/libXfixes
-	x11-libs/libxkbcommon
-	x11-libs/libXmu
-	x11-libs/libXrender
-	x11-libs/libXres
-	x11-libs/libXtst
-	x11-libs/libXxf86vm
-	pipewire? ( >=media-video/pipewire-0.3:= )
-	wsi-layer? ( x11-libs/libxcb )
-"
-DEPEND="
-	${RDEPEND}
-	dev-libs/stb
-	dev-util/vulkan-headers
-	media-libs/glm
-	dev-util/spirv-headers
-	wsi-layer? ( >=media-libs/vkroots-0_p20231108 )
-"
-BDEPEND="
-	dev-util/glslang
-	dev-util/wayland-scanner
-	virtual/pkgconfig
-"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-FILECAPS=(
-	cap_sys_nice usr/bin/${PN}
-)
-
-src_prepare() {
-	default
-
-	# Normally wraps stb with Meson. Upstream does not ship a pkg-config file so
-	# we don't install one. Work around this using symlinks.
-	mkdir subprojects/stb || die
-	ln -sn "${ESYSROOT}"/usr/include/stb/* "${S}"/subprojects/packagefiles/stb/* subprojects/stb/ || die
-
-	# ReShade is bundled as a git submodule, but it references an unofficial
-	# fork, so we cannot unbundle it. Symlink to its extracted sources.
-	rmdir src/reshade || die
-	ln -snfT ../../reshade-${RESHADE_COMMIT} src/reshade || die
-
-	# SPIRV-Headers is required by ReShade. It is bundled as a git submodule but
-	# not wrapped with Meson, so we can symlink to our system-wide headers.
-	mkdir thirdparty/SPIRV-Headers/include || die
-	ln -snf "${ESYSROOT}"/usr/include/spirv thirdparty/SPIRV-Headers/include/ || die
-}
-
-src_configure() {
-	local emesonargs=(
-		--force-fallback-for=
-		-Dbenchmark=disabled
-		-Denable_openvr_support=false
-		$(meson_feature pipewire)
-		$(meson_use wsi-layer enable_gamescope_wsi_layer)
-	)
-	meson_src_configure
-}
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 6fec3df2e089..7cdbf8d4e07c 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -3,6 +3,8 @@ AUX hyprland-0.30.0-no-wlroots-automagic-r1.patch 760 BLAKE2B 386b70de5c525fb1f1
 AUX hyprland-0.31.0-fix-log-headers.patch 865 BLAKE2B c8173cdac049a5914c3f00261300ef5d9dbfd89b0e8ff643b97b86bc590fb23b5824005cd42a9f790bf1766843bf92765cbd0b65b0a2ef8390505e47dcc6771b SHA512 f6546c729596a18d91471e1853c5a377c05637e572814006635d039f027a4943fea13206794ed537862e83b708e1a49b81db874362073ec267b5f0f378b98696
 DIST hyprland-0.31.0.gh.tar.gz 14068621 BLAKE2B 272ba0c92ee6f8db623bb7b79a64ec1a3f2d2e0e1a8825ab7cc43e30dc64d77396ae014469a308c10deea0f9607680ff3a9328b747c82acccd5156e9d9c07cde SHA512 27798eba3bc430fe3689ecfb6ae38a59f48c39183c8cbd4fea8dca0a92a25941e6ee8b51d70f18498a3b0ef6c2575658299ee36ed6a6a93c7b54548ab64f07ca
 DIST hyprland-0.32.0.gh.tar.gz 14123937 BLAKE2B 3eb3c105681c22a1a4b2e38805a55015b741061977976f8e429068b79a59bfd6bac2ba74b2f547d81481cb404cad41bdec73eee67704bd11fddab3c213085a56 SHA512 293f0814530008f2f4561526aaca86a454de62bfae7ab508cf7ecdc12ec7029ba1fac2bb918cf0a2d4e8e9b423b463e5120591ebc8579489dcb7e07751d89ac9
+DIST hyprland-0.32.2.gh.tar.gz 14119309 BLAKE2B 5a8924601d8db994532bbb7fc96962a9c8f9f11a52ee77c13c20cafc647617ba7eec2f4eea3672ba78decf5573b5a0394b73cb6041c2ea2f742e9557d14ff10b SHA512 6736c307bb29ddbfa46ed42b73c2cbe24bbf4b3a7113d370daba001dc1ace73f9e4174ad3e55e84b753fa57b42dccd618816408daa24eeef566b1bc70d729860
 EBUILD hyprland-0.31.0-r1.ebuild 3415 BLAKE2B c8634bb8e1f9a41b15020c9e371c3436e8f13a38485bce5501ea9cb4ea735da73cea2634174366c7e48b809a94f5940b6abc9ae1b8ad057cf3bede15b57308cb SHA512 24158c58189098cea877501c444ed48c9de84414f2c9c04a70db5966cf3a3c24f6721dbe6b4165c1f3c842231b31a6191db50ba39efcc96f8c8424738b406687
 EBUILD hyprland-0.32.0.ebuild 3357 BLAKE2B 03ac7c29e3ce75a9acae4acfac8adae2e9d392665bd0a17fbf7d39fd5a1a97447b70ae2cf306ba8c5814756dce213e51d36dcd51d28d5227a88c3260da0f276e SHA512 e96549beb540ffad93f4ffa0b669354538b599104ba7fb4a3dcca87bbd7cf2a336818df9c69948fcf06c436524336fe838ab83094ff8c4a168b8873081a31f37
+EBUILD hyprland-0.32.2.ebuild 3357 BLAKE2B 03ac7c29e3ce75a9acae4acfac8adae2e9d392665bd0a17fbf7d39fd5a1a97447b70ae2cf306ba8c5814756dce213e51d36dcd51d28d5227a88c3260da0f276e SHA512 e96549beb540ffad93f4ffa0b669354538b599104ba7fb4a3dcca87bbd7cf2a336818df9c69948fcf06c436524336fe838ab83094ff8c4a168b8873081a31f37
 MISC metadata.xml 716 BLAKE2B fc5248c809b9b5bf1002e3d82ff80f595b8e613d09e5541f1a0151c3ea2c117376d25fa5a40c85d254533708d9eff5339bd329b42118e87ca49e22e55c0c5d7b SHA512 31252ced2546f3686f17259aabfe9273af14f7efaf3fa0bfb446c65c6d9478be3a23c531e0ac463f27fe1d50842f6f126f32e47a8a03a345306297e182952e98
diff --git a/gui-wm/hyprland/hyprland-0.32.2.ebuild b/gui-wm/hyprland/hyprland-0.32.2.ebuild
new file mode 100644
index 000000000000..c77204ea1933
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.32.2.ebuild
@@ -0,0 +1,130 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-source"
+
+KEYWORDS="~amd64 ~riscv"
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd video_cards_nvidia"
+
+# bundled wlroots has the following dependency string according to included headers.
+# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
+# enable x11-backend with X and vice versa
+WLROOTS_RDEPEND="
+	>=dev-libs/libinput-1.14.0:=
+	dev-libs/libliftoff
+	>=dev-libs/wayland-1.22
+	media-libs/libdisplay-info
+	media-libs/libglvnd
+	media-libs/mesa[egl(+),gles2]
+	sys-apps/hwdata:=
+	sys-auth/seatd:=
+	>=x11-libs/libdrm-2.4.114
+	x11-libs/libxkbcommon
+	>=x11-libs/pixman-0.42.0
+	virtual/libudev:=
+	X? (
+		x11-base/xwayland
+		x11-libs/libxcb:0=
+		x11-libs/xcb-util-renderutil
+		x11-libs/xcb-util-wm
+	)
+"
+WLROOTS_DEPEND="
+	>=dev-libs/wayland-protocols-1.32
+"
+WLROOTS_BDEPEND="
+	dev-util/glslang
+	dev-util/wayland-scanner
+"
+
+RDEPEND="
+	${WLROOTS_RDEPEND}
+	dev-libs/glib:2
+	dev-libs/libinput
+	dev-libs/wayland
+	media-libs/libglvnd
+	x11-libs/cairo
+	x11-libs/libdrm
+	x11-libs/libxkbcommon
+	x11-libs/pango
+	x11-libs/pixman
+	X? (
+		x11-libs/libxcb:0=
+	)
+"
+DEPEND="
+	${RDEPEND}
+	${WLROOTS_DEPEND}
+	dev-libs/hyprland-protocols
+	>=dev-libs/wayland-protocols-1.25
+"
+BDEPEND="
+	${WLROOTS_BDEPEND}
+	|| ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+	app-misc/jq
+	dev-util/cmake
+	dev-util/wayland-scanner
+	dev-vcs/git
+	virtual/pkgconfig
+"
+
+pkg_setup() {
+	[[ ${MERGE_TYPE} == binary ]] && return
+
+	if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+		eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+		eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+		die "GCC version is too old to compile Hyprland!"
+	elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+		eerror "Hyprland requires >=sys-devel/clang-16 to build"
+		eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+		die "Clang version is too old to compile Hyprland!"
+	fi
+}
+
+src_prepare() {
+	if use video_cards_nvidia; then
+		cd "${S}/subprojects/wlroots" || die
+		eapply "${S}/nix/patches/wlroots-nvidia.patch"
+		cd "${S}" || die
+	fi
+
+	default
+}
+
+src_configure() {
+	local emesonargs=(
+		$(meson_feature legacy-renderer legacy_renderer)
+		$(meson_feature systemd)
+		$(meson_feature X xwayland)
+		$(meson_feature X wlroots:xwayland)
+		-Dwlroots:backends=drm,libinput$(usev X ',x11')
+		-Dwlroots:xcb-errors=disabled
+	)
+
+	meson_src_configure
+}
+
+src_install() {
+	meson_src_install --skip-subprojects wlroots
+	meson_src_install --tags devel
+
+	# Wlroots headers are required by hyprland-plugins and the pkgconfig file expects
+	# them to be in /usr/include/hyprland/wlroots, despite this they aren't installed there.
+	# Ideally you could override includedir per subproject and the install tags would
+	# be granular enough to only install headers. But its not requiring this.
+	mkdir "${ED}"/usr/include/hyprland/wlroots || die
+	mv "${ED}"/usr/include/wlr "${ED}"/usr/include/hyprland/wlroots || die
+	# devel tag includes wlroots .pc and .a files still
+	rm -rf "${ED}"/usr/$(get_libdir)/ || die
+}
-- 
cgit v1.2.3