From c59fc2181f7402f8d0a548bcc897584a83139cc1 Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Sun, 7 May 2023 05:35:45 +0100
Subject: gentoo auto-resync : 07:05:2023 - 05:35:45

---
 media-libs/Manifest.gz                 | Bin 68074 -> 68079 bytes
 media-libs/gexiv2/Manifest             |   2 +
 media-libs/gexiv2/gexiv2-0.14.1.ebuild |  77 +++++++++++++++++++++++++++++++++
 3 files changed, 79 insertions(+)
 create mode 100644 media-libs/gexiv2/gexiv2-0.14.1.ebuild

(limited to 'media-libs')

diff --git a/media-libs/Manifest.gz b/media-libs/Manifest.gz
index 5d8a487134f3..0d00ccffc84c 100644
Binary files a/media-libs/Manifest.gz and b/media-libs/Manifest.gz differ
diff --git a/media-libs/gexiv2/Manifest b/media-libs/gexiv2/Manifest
index 5450325dc123..258f141d199a 100644
--- a/media-libs/gexiv2/Manifest
+++ b/media-libs/gexiv2/Manifest
@@ -1,4 +1,6 @@
 AUX 0.14.0-clean-up-python-support.patch 7005 BLAKE2B 623b003ab5c03ed86585ac662c5ddae0857bc09ddf28f5a42ea40f60601758111bcb408f38bfaa1aa081d882750d343eef355977da2ee84b3a9675d560243e11 SHA512 3de9ec1e11e859b393e16ae9d6a15e98157869b8b9cb2e939e8642eb4f38e9aaca05c969094dae001425475113ce4dc0224d3bcffd72a581b310174d039d1fd8
 DIST gexiv2-0.14.0.tar.xz 387288 BLAKE2B bdbb4547486a248cd9c6559276ebac20d3af5211474b86eb6ebfb3a8c76670ff7c2d162435e0cbcb270f96c64f5bc1eedc2d63c021b65f57e1ad9ec8cf9a4bf8 SHA512 d745ae2d8ddcf0c8a2a7980eaa489f9b520af54242c5e4ddded9c3ae4a579c824c8cb659bd7e985ffa09f9fe37bdf73d6d9181d456711e0953b73023eb0f9f50
+DIST gexiv2-0.14.1.tar.xz 387604 BLAKE2B 5939e377d8b20cfa0c000b1fb0311a0a904acb35b5cbb7841e9def80b20b79f42393524e761fa0d20dba5095b55b46a712759569eb869b832190f7448896de82 SHA512 f510e49c0b2633bcc370ca21af0822032f04f5d5b57c7f76807797601b0a98b7749fdf68df37a405c9d90734adf75282a3dad59c24830874f64f7bd33152052d
 EBUILD gexiv2-0.14.0.ebuild 1876 BLAKE2B 46df7ac87775001557d46b06e9bda3439054c1457f246984ffcc2cb1ca4e7b8c8c27f41d446331bd36c92486a18f366b7c6ba59757643bdf658664ba182f7d3a SHA512 a02d4cea39bcef8f5483e8bd7a260fabe78facf73812b9f79649388782a5d0710163d619cc6d7f8371115f32fbcee8efad6aba9dfc9cc6379c1ed70201e59845
+EBUILD gexiv2-0.14.1.ebuild 1775 BLAKE2B 81f6bedcc51ad8d888dc13e9be2f1b55ee4805c1adcd0a085e1ade452fe90d5faa8b76e7744e86270a56cb7d377925b83334753266cf5b59462d727378a0cb24 SHA512 718cf944d611821ad2853f4aa6054a5358a81fe8adf0b0b8200133e8dc95264f8e0c74da729dc116caa3244d540374fa5d6061e8d633202ce45421eba1bbd358
 MISC metadata.xml 615 BLAKE2B 76b7eab8ca423cb9a816de9ee01bcf7211b14da002292e95bda41db4ed779523b97b95115803ab10ba6b4117c03ff1fd83308d6eac111c1a7813620cc5c56080 SHA512 0a85fe161f01d944a319018dd1dd63b96eafb1d83f3547c707498697dc554088c5ab9fa8fd978a326357fc8a78728e548da2f16b2ccfdcbd2b6c68c5d3623f85
diff --git a/media-libs/gexiv2/gexiv2-0.14.1.ebuild b/media-libs/gexiv2/gexiv2-0.14.1.ebuild
new file mode 100644
index 000000000000..3d6e9af9775e
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.14.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome.org meson python-r1 vala
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+
+if [[ ${PV} == 9999 ]]; then
+	EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gexiv2.git"
+	inherit git-r3
+else
+	KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2.1+ GPL-2"
+SLOT="0"
+IUSE="gtk-doc +introspection python test +vala"
+REQUIRED_USE="
+	python? ( introspection ${PYTHON_REQUIRED_USE} )
+	test? ( python introspection )
+	vala? ( introspection )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+	>=media-gfx/exiv2-0.26:=
+	>=dev-libs/glib-2.46.0:2
+	introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+	python? (
+		${PYTHON_DEPS}
+		dev-python/pygobject:3[${PYTHON_USEDEP}]
+	)
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+	dev-util/glib-utils
+	gtk-doc? (
+		dev-util/gtk-doc
+		app-text/docbook-xml-dtd:4.3
+	)
+	test? ( media-gfx/exiv2[xmp] )
+	virtual/pkgconfig
+	vala? ( $(vala_depend) )
+"
+src_prepare() {
+	default
+	use vala && vala_setup
+}
+
+src_configure() {
+	local emesonargs=(
+		$(meson_use test tests)
+		$(meson_use gtk-doc gtk_doc)
+		$(meson_use introspection)
+		$(meson_use vala vapi)
+		-Dtools=false # requires vala, freshly promoted tool that some other distros don't ship yet either
+		# Prevents installation of python modules (uses install_data from meson
+		# which does not optimize the modules)
+		-Dpython3=false
+	)
+	meson_src_configure
+}
+
+src_install() {
+	meson_src_install
+
+	if use python ; then
+		python_moduleinto gi/overrides/
+		python_foreach_impl python_domodule GExiv2.py
+		python_foreach_impl python_optimize
+	fi
+}
-- 
cgit v1.2.3