From 9b921f0a27acb73f29835bcf94b91bbdef87e9de Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Wed, 14 Dec 2022 15:30:24 +0000
Subject: gentoo auto-resync : 14:12:2022 - 15:30:24

---
 net-im/Manifest.gz                   | Bin 10256 -> 10257 bytes
 net-im/prosody/Manifest              |   2 +
 net-im/prosody/prosody-0.12.2.ebuild | 164 +++++++++++++++++++++++++++++++++++
 3 files changed, 166 insertions(+)
 create mode 100644 net-im/prosody/prosody-0.12.2.ebuild

(limited to 'net-im')

diff --git a/net-im/Manifest.gz b/net-im/Manifest.gz
index 724389601f1d..c6f798ed13d4 100644
Binary files a/net-im/Manifest.gz and b/net-im/Manifest.gz differ
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index 5c16a1103f88..53cbe4d9a85b 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -3,5 +3,7 @@ AUX prosody.initd-r6 1114 BLAKE2B a988b584eb49d21261776fa0a651dc01d3943a5a75c9bf
 AUX prosody.service-r3 439 BLAKE2B abd128f236f2c28f54542388a38aaa3d0e5030510dddc16240273de90c13ddee62d01d26d7c9e1be0635dc59ad9ca5e93a30f2b5fa42106489a95d26a037314a SHA512 b540e5d4389439cdd2886f9ccaf189d20ffcaf29a982a26e4ed296b0c529df95aade88751d22919cb36b27db94530dade754044d50cee2e5244d37983b933517
 AUX prosody.tmpfilesd-r2 39 BLAKE2B 1e004bf2bf1495d219c12bea1973206fae135fb4a5b453c6692f0143413626ec83889bb84b5086a6e507d3b8af14877b3820f3d9560df17e1ca49e2cbee85e0b SHA512 81b855c6bf496f0e6f20c41b8be5538c4edd1fbc6e4f2ca6e9a2d0a06bd5237223a4d42bcbdb75746cb01e46ff0eb36dac6952d9c076c6a72d1bbd733aca07eb
 DIST prosody-0.12.1.tar.gz 611898 BLAKE2B 0b65ffbd6d4703f9e5fbac80e8887a4a41297afd22a776fb2eaa718b309f46c55a9d78f1d3ea97d4434c6ea2ebfe7a9051532ceda25ad78611769bd031894084 SHA512 705d2bcd38ffb19e90dab19992711aebf3d81f7bca7f9791ae5149510d465ec837ddf26a8c547eff2f2d131e5a694ddc3d0aac0b8921df65808192ae00527a85
+DIST prosody-0.12.2.tar.gz 614303 BLAKE2B f44f2106e3064b6ecb5d75718997ed980309e9debbd9f0b17eaeb3261d27421774097ba16bfd8d86d4bf1dd8f427c653b494b199676738d8781ffa37f9b73c5f SHA512 dd14d2740b67127e7edcf79db7d1fd81b4566d4a285430edb9dd7263ad109fdd6e581a1d93fcbf971f73fa5ba051ae7935a121d31e3e7448cacfcd8ecbd802bb
 EBUILD prosody-0.12.1.ebuild 5129 BLAKE2B 75cdba4ad8d2ea935d800385b1397d90dd3df43a5f03e0e6d3afec15001d8897b6eb271f7c91843b19ca672d46642b92f9f20d5ac00f57fe7ed73a0f9658f7df SHA512 c2fa2d60436e6b8d433b069f3f9266369ed87bd73142a07364e555c748169f25bb1c2c45504a427d827cac8b52a3d2ce6c74fce9674d9b4c7cb22f9fe7d0e536
+EBUILD prosody-0.12.2.ebuild 5131 BLAKE2B 32986fdee941501782c3a6f211401e0b53b404e5823d466bd3b89ec16a475d8b5f5fd874c028167ace137d7856556b3010341f3878b846210b63440c6ba35520 SHA512 52c336be8e9a097c0d3a76b487d63b37cbd4d925107e7cc6b9ee187a05612ca03f53fba9aa6c98044c134d06f303a4e13802e7421c081ec2d7a7fdfbfcdedb9f
 MISC metadata.xml 670 BLAKE2B 448bf5ede2b6f09940c51fdff4642e18be22d9c3dac637271c7c8bcfde1b4af0853e2623c55c00efcd8757ef863ac37fdb895606e572911a62a1c9d5f32cc693 SHA512 6177b8e3d2ed1aeeae2f369dc693283a3f811953f71be0e004eea402aa421d89973dbefe79c8fd198e9f9f82e4b345552dc3a2c3597c05927dc1a518cacbaf1d
diff --git a/net-im/prosody/prosody-0.12.2.ebuild b/net-im/prosody/prosody-0.12.2.ebuild
new file mode 100644
index 000000000000..e9cab9fb7d64
--- /dev/null
+++ b/net-im/prosody/prosody-0.12.2.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+LUA_REQ_USE="deprecated(+)"
+
+inherit lua-single systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Prosody is a modern XMPP communication server"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="icu +idn +libevent ldap mysql postgres selinux +sqlite +ssl test +zlib"
+REQUIRED_USE="
+	^^ ( icu idn )
+	${LUA_REQUIRED_USE}
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+	acct-group/prosody
+	acct-user/prosody
+	$(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
+	$(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
+	dev-lua/luarocks[${LUA_SINGLE_USEDEP}]
+	$(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
+	$(lua_gen_cond_dep 'dev-lua/lua-unbound[${LUA_USEDEP}]')
+	$(lua_gen_cond_dep 'dev-lua/readline[${LUA_USEDEP}]')
+	icu? ( dev-libs/icu:= )
+	idn? ( net-dns/libidn:= )
+	ldap? ( $(lua_gen_cond_dep 'dev-lua/lualdap[${LUA_USEDEP}]') )
+	libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
+	dev-libs/openssl:0=
+	lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
+	mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
+	postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
+	sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
+	ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
+	zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
+	${LUA_DEPS}
+"
+
+RDEPEND="
+	${DEPEND}
+	selinux? ( sec-policy/selinux-jabber )
+"
+
+BDEPEND="
+	virtual/pkgconfig
+	test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.12.0-gentoo.patch" )
+
+src_prepare() {
+	default
+
+	# Set correct plugin path for optional net-im/prosody-modules package
+	sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
+}
+
+src_configure() {
+	local myeconfargs=(
+		--add-cflags="${CFLAGS}"
+		--add-ldflags="${LDFLAGS}"
+		--c-compiler="$(tc-getCC)"
+		--datadir="${EPREFIX}/var/lib/prosody"
+		--idn-library="$(usex idn 'idn' 'icu')"
+		--libdir="${EPREFIX}/usr/$(get_libdir)"
+		--linker="$(tc-getCC)"
+		--lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
+		--no-example-certs
+		--ostype="linux"
+		--prefix="${EPREFIX}/usr"
+		--runwith="${ELUA}"
+		--sysconfdir="${EPREFIX}/etc/prosody"
+		--with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
+		--with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
+	)
+
+	# Since the configure script is handcrafted,
+	# and yells at unknown options, do not use 'econf'.
+	./configure "${myeconfargs[@]}" || die
+
+	rm makefile || die
+	mv GNUmakefile Makefile || die
+}
+
+src_install() {
+	default
+
+	keepdir /var/lib/prosody
+
+	newinitd "${FILESDIR}"/prosody.initd-r6 prosody
+	systemd_newunit "${FILESDIR}"/prosody.service-r3 prosody.service
+
+	newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r2 prosody.conf
+}
+
+pkg_postinst() {
+	local migrate_to_prosody_user="false"
+	tmpfiles_process prosody.conf
+
+	if [[ ${REPLACING_VERSIONS} ]]; then
+		for v in ${REPLACING_VERSIONS}; do
+			if ver_test "${v}" -lt 0.12.0; then
+				migrate_to_prosody_user="true"
+				break
+			fi
+		done
+	fi
+
+	# Sarting with >=0.12.0, the prosody configuration is now in
+	# /etc/prosody and no longer in /etc/jabber.
+	# See if we need to migrate the configuration. Furthermore,
+	# prosody no longer runs under the, shared via net-im/jabber-base,
+	# 'jabber' use, but under its own user.
+	# This increase isolation and hence robustness and security.
+	if ${migrate_to_prosody_user}; then
+		local -A dirs_to_migrate=(
+			[/etc/jabber]=/etc/prosody
+			[/var/log/jabber]=/var/log/prosody
+			[/var/spool/jabber]=/var/lib/prosody
+		)
+
+		for src_dir in "${!dirs_to_migrate[@]}"; do
+			local eroot_src_dir="${EROOT}/${src_dir}"
+			local eroot_dst_dir="${EROOT}/${dirs_to_migrate[${src_dir}]}"
+
+			cp -r "${eroot_src_dir}"/. "${eroot_dst_dir}" || die "Could not copy ${eroot_src_dir} to ${eroot_dst_dir}"
+
+			if [[ -f "${eroot_dst_dir}"/.keep_net-im_jabber-base-0 ]]; then
+				rm "${eroot_dst_dir}"/.keep_net-im_jabber-base-0 || die
+			fi
+
+			if ! use prefix; then
+				chown --recursive prosody:prosody "${eroot_dst_dir}" || die
+			fi
+		done
+
+		# Update configuration file to match new pathes and permissions
+		local mysedargs=(
+			-e "'s#/etc/jabber#/etc/prosody#g'"
+			-e "'s#/run/jabber#/run/prosody#g'"
+			-e "'s#/var/log/jabber#/var/log/prosody#g'"
+			-e "'s/prosody_user.*/prosody_user = \"prosody\";/g'"
+			-e "'s/prosody_group.*/prosody_group = \"prosody\";/g'"
+			-i /etc/prosody/prosody.cfg.lua
+		)
+
+		eval sed "${mysedargs[@]}" || die
+
+		ewarn "Newer versions of the prosody (Gentoo) package use ${EROOT}/etc/prosody"
+		ewarn "(just as upstream) and *not* anymore ${EROOT}/etc/jabber."
+		ewarn "The files from ${EROOT}/etc/jabber where copied to ${EROOT}/etc/prosody."
+		ewarn "Also prosody's spool directory became ${EROOT}/var/lib/prosody (was ${EROOT}/var/spool/jabbber)."
+		ewarn "Please check your configuration."
+	fi
+}
-- 
cgit v1.2.3