From ce23b28e3d5f58b4177dfa6006db905a41dd87ee Mon Sep 17 00:00:00 2001
From: V3n3RiX <venerix@koprulu.sector>
Date: Sun, 30 Apr 2023 17:17:49 +0100
Subject: gentoo auto-resync : 30:04:2023 - 17:17:49

---
 x11-libs/Manifest.gz                   | Bin 18491 -> 18490 bytes
 x11-libs/wxGTK/Manifest                |   1 +
 x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild | 225 +++++++++++++++++++++++++++++++++
 3 files changed, 226 insertions(+)
 create mode 100644 x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild

(limited to 'x11-libs')

diff --git a/x11-libs/Manifest.gz b/x11-libs/Manifest.gz
index 2aea4a3bfaf4..2602789ca856 100644
Binary files a/x11-libs/Manifest.gz and b/x11-libs/Manifest.gz differ
diff --git a/x11-libs/wxGTK/Manifest b/x11-libs/wxGTK/Manifest
index 3d5c52bc3b6a..982393cc2579 100644
--- a/x11-libs/wxGTK/Manifest
+++ b/x11-libs/wxGTK/Manifest
@@ -21,4 +21,5 @@ EBUILD wxGTK-3.0.4-r5.ebuild 3752 BLAKE2B 57acf7f620095191b662e806496ddc5ed38fed
 EBUILD wxGTK-3.0.5.1-r1.ebuild 5495 BLAKE2B f3daf6569a27e61c3cb60eef9a29aea35305e48523ef6572639905e81757f12e5a41b9e93fecbfdcdb5bf55a29db7d47515d0e2c9c40630bc4b611fa4cc17665 SHA512 2718f47aed0f875407117f85b28f7ba385e2def712fe7be4256d94211ef0d56f7e5eee0f72cc94644500f93c6b5e75ea01c16009ea7065cf112b3d102c6c6a7b
 EBUILD wxGTK-3.2.1.ebuild 6886 BLAKE2B 00c0384db71bc25f73a390ab4c27c104b3b560e0bd149cf54cf2384830df82c02227afb556518e973c3eaf14a639119c5a0e6a87dd71d57d40edcb345da83223 SHA512 d234b1c37b35976fc7db54ec7f6663b1a7b22b9453ac2d0514033dd4093dd975593489912315f1244a7e94791e35a6604e211802e04f9152ec7f713f5edf89ad
 EBUILD wxGTK-3.2.2.1-r1.ebuild 7030 BLAKE2B dcfe33ba3c9b93274f8e1c9b37e313a892ac899fc0c1d4bb4fff2cf0187e7d47087d97b24187a39426f5769342ddfcc00c4ac4a9e61ac4f0e00758efe03cf2b8 SHA512 9ac0eb1da98f0f667e16c711f193508dcfe1120ff917a37646d6c273f025317c049de45ba7719ed8253ac56551e0bbbd369e16c488d8d61444efd5fe495577f2
+EBUILD wxGTK-3.2.2.1-r2.ebuild 7035 BLAKE2B 05b54cf085bd7c4ef575c11424df27a853065e5dd0fb64b20943994762f5a7df35e32944c0b458447f713b6014a1ffd84ca2c00b288d768b0fd2ce21488084ca SHA512 59865de31f9bb9647ae8dd1e1f07ec4f8f42238bb731c99cc54df4326fdfc0307bdc1fc87432528da851bee697d7338deda88f678aa57a28d2766b6688865d51
 MISC metadata.xml 756 BLAKE2B 336ffb3375ee9092de02d0808d0a44f7f5bcbc6e4a845c12b6466af0b91f3397c2b335e5433917361a060db43d6cb836cde0f87be2059214f314fa6726199e2d SHA512 190b72992c64b43b46e28ca2f730e1897a5f740ba211b859c816b4892256284feb579fbce06cb1939b774ae989dc68754f5a57f6375cfca50d7770d0c2ed47ed
diff --git a/x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild b/x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild
new file mode 100644
index 000000000000..57078c052027
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-3.2.2.1-r2.ebuild
@@ -0,0 +1,225 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+WXSUBVERSION="${PV}-gtk3"				# 3.2.1-gtk3
+WXVERSION="$(ver_cut 1-3)"				# 3.2.1
+# Make sure that this matches the number of components in ${PV}
+WXRELEASE="$(ver_cut 1-2)-gtk3"			# 3.2-gtk3
+WXRELEASE_NODOT=${WXRELEASE//./}		# 32-gtk3
+
+DESCRIPTION="GTK version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="https://wxwidgets.org/"
+SRC_URI="
+	https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}.tar.bz2
+	doc? ( https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}-docs-html.tar.bz2 )"
+S="${WORKDIR}/wxWidgets-${PV}"
+
+LICENSE="wxWinLL-3 GPL-2 doc? ( wxWinFDL-3 )"
+SLOT="${WXRELEASE}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+X curl doc debug gnome-keyring gstreamer libnotify +lzma opengl pch sdl +spell test tiff wayland webkit"
+REQUIRED_USE="test? ( tiff ) tiff? ( X ) spell? ( X ) gnome-keyring? ( X )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+	>=app-eselect/eselect-wxwidgets-20131230
+	dev-libs/expat[${MULTILIB_USEDEP}]
+	dev-libs/libpcre2[pcre16,pcre32,unicode]
+	sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+	curl? ( net-misc/curl )
+	lzma? ( app-arch/xz-utils )
+	X? (
+		>=dev-libs/glib-2.22:2[${MULTILIB_USEDEP}]
+		media-libs/libjpeg-turbo:=[${MULTILIB_USEDEP}]
+		media-libs/libpng:0=[${MULTILIB_USEDEP}]
+		sys-libs/zlib[${MULTILIB_USEDEP}]
+		x11-libs/cairo[${MULTILIB_USEDEP}]
+		x11-libs/gtk+:3[wayland?,${MULTILIB_USEDEP}]
+		x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+		x11-libs/libSM[${MULTILIB_USEDEP}]
+		x11-libs/libX11[${MULTILIB_USEDEP}]
+		x11-libs/libXtst
+		x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+		media-libs/fontconfig
+		x11-libs/pango[${MULTILIB_USEDEP}]
+		gnome-keyring? ( app-crypt/libsecret )
+		gstreamer? (
+			media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
+			media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
+			media-libs/gst-plugins-bad:1.0[${MULTILIB_USEDEP}]
+		)
+		libnotify? ( x11-libs/libnotify[${MULTILIB_USEDEP}] )
+		opengl? (
+			virtual/opengl[${MULTILIB_USEDEP}]
+			wayland? ( dev-libs/wayland )
+		)
+		spell? ( app-text/gspell:= )
+		tiff? ( media-libs/tiff:=[${MULTILIB_USEDEP}] )
+		webkit? ( net-libs/webkit-gtk:4= )
+	)"
+DEPEND="${RDEPEND}
+	opengl? ( virtual/glu[${MULTILIB_USEDEP}] )
+	X? ( x11-base/xorg-proto )"
+BDEPEND="
+	test? ( >=dev-util/cppunit-1.8.0 )
+	>=app-eselect/eselect-wxwidgets-20131230
+	virtual/pkgconfig"
+
+# Note about the gst-plugin-base dep: The build system queries for it,
+# but doesn't link it for some reason?  Either way - probably best to
+# depend on it anyway.
+# Note about the wayland dep: Appears to be only required for the OpenGL
+# canvas, and it seems impossible to disable the X dependency, unless
+# I'm missing something.  This is an automagic header dep, though.
+
+PATCHES=(
+	#"${WORKDIR}"/wxGTK-3.0.5_p20210214/
+	"${FILESDIR}/${PN}-3.2.1-gtk3-translation-domain.patch"
+	#"${FILESDIR}"/wxGTK-ignore-c++-abi.patch #676878
+	"${FILESDIR}/${PN}-3.2.1-configure-tests.patch"
+	"${FILESDIR}/${PN}-3.2.1-wayland-control.patch"
+	"${FILESDIR}/${PN}-3.2.1-prefer-lib64-in-tests.patch"
+	"${FILESDIR}/${PN}-3.2.2.1-dont-break-flags.patch"
+)
+
+src_prepare() {
+	default
+
+	# find . -iname Makefile.in -not -path ./samples'/*' \
+	#        | xargs grep -l WX_RELEASE
+	local versioned_makefiles=(
+		./tests/benchmarks/Makefile.in
+		./tests/Makefile.in
+		./utils/emulator/src/Makefile.in
+		./utils/execmon/Makefile.in
+		./utils/wxrc/Makefile.in
+		./utils/helpview/src/Makefile.in
+		./utils/hhp2cached/Makefile.in
+		./utils/screenshotgen/src/Makefile.in
+		./utils/ifacecheck/src/Makefile.in
+		./Makefile.in
+		./demos/life/Makefile.in
+		./demos/bombs/Makefile.in
+		./demos/fractal/Makefile.in
+		./demos/forty/Makefile.in
+		./demos/poem/Makefile.in
+	)
+
+	# Versionating
+	sed -i \
+		-e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\
+		-e "s:\(WX_RELEASE_NODOT = \).*:\1${WXRELEASE_NODOT}:"\
+		-e "s:\(WX_VERSION = \).*:\1${WXVERSION}:"\
+		-e "s:aclocal):aclocal/wxwin${WXRELEASE_NODOT}.m4):" \
+		"${versioned_makefiles[@]}" || die
+
+	sed -i \
+		-e "s:\(WX_VERSION=\).*:\1${WXVERSION}:" \
+		-e "s:\(WX_RELEASE=\).*:\1${WXRELEASE}:" \
+		-e "s:\(WX_SUBVERSION=\).*:\1${WXSUBVERSION}:" \
+		-e '/WX_VERSION_TAG=/ s:${WX_RELEASE}:3.0:' \
+		configure || die
+}
+
+multilib_src_configure() {
+	# X independent options
+	local myeconfargs=(
+		--with-zlib=sys
+		--with-expat=sys
+		--enable-compat30
+		--enable-xrc
+		$(use_with sdl)
+		$(use_with lzma liblzma)
+		# Currently defaults to curl, could change.  Watch the VDB!
+		$(use_enable curl webrequest)
+
+		# PCHes are unstable and are disabled in-tree where possible
+		# See bug #504204
+		# Commits 8c4774042b7fdfb08e525d8af4b7912f26a2fdce, fb809aeadee57ffa24591e60cfb41aecd4823090
+		$(use_enable pch precomp-headers)
+
+		# Don't hard-code libdir's prefix for wx-config
+		--libdir='${prefix}'/$(get_libdir)
+	)
+
+	# debug in >=2.9
+	# there is no longer separate debug libraries (gtk2ud)
+	# wxDEBUG_LEVEL=1 is the default and we will leave it enabled
+	# wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
+	# apps can disable these features by building w/ -NDEBUG or wxDEBUG_LEVEL_0.
+	# http://docs.wxwidgets.org/3.0/overview_debugging.html
+	# https://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
+	use debug && myeconfargs+=( --enable-debug=max )
+
+	# wxGTK options
+	#   --enable-graphics_ctx - needed for webkit, editra
+	#   --without-gnomevfs - bug #203389
+	use X && myeconfargs+=(
+		--enable-graphics_ctx
+		--with-gtkprint
+		--enable-gui
+		--with-gtk=3
+		--with-libpng=sys
+		--with-libjpeg=sys
+
+		# Choosing to enable this unconditionally seems fair, pcre2 is
+		# almost certain to be installed.
+		--with-regex=sys
+		--without-gnomevfs
+		$(use_enable gstreamer mediactrl)
+		$(multilib_native_use_enable webkit webview)
+		$(use_with libnotify)
+		$(use_with opengl)
+		$(use_with tiff libtiff sys)
+		$(use_enable gnome-keyring secretstore)
+		$(use_enable spell spellcheck)
+		$(use_enable test tests)
+		$(use_enable wayland)
+	)
+
+	# wxBase options
+	! use X && myeconfargs+=( --disable-gui )
+
+	ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+	emake -C tests
+	(cd tests && ./test '~[.]~[net]') || die
+}
+
+multilib_src_install_all() {
+	cd docs || die
+	dodoc changes.txt readme.txt
+	newdoc base/readme.txt base_readme.txt
+	newdoc gtk/readme.txt gtk_readme.txt
+
+	use doc && HTML_DOCS=( "${WORKDIR}"/wxWidgets-${PV}-docs-html/. )
+	einstalldocs
+
+	# Unversioned links
+	rm "${ED}"/usr/bin/wx-config || die
+	rm "${ED}"/usr/bin/wxrc || die
+
+	# version bakefile presets
+	pushd "${ED}"/usr/share/bakefile/presets >/dev/null || die
+	local f
+	for f in wx*; do
+		mv "${f}" "${f/wx/wx32gtk3}" || die
+	done
+	popd >/dev/null || die
+}
+
+pkg_postinst() {
+	has_version -b app-eselect/eselect-wxwidgets \
+		&& eselect wxwidgets update
+}
+
+pkg_postrm() {
+	has_version -b app-eselect/eselect-wxwidgets \
+		&& eselect wxwidgets update
+}
-- 
cgit v1.2.3