summaryrefslogtreecommitdiff
path: root/app-editors/featherpad/featherpad-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-24 03:26:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-24 03:26:58 +0100
commitba99df89fd07a4f3ed2d083249a758ae6a2a04c9 (patch)
tree9eef5664bff1e16203d42113b6610a249bdf85a6 /app-editors/featherpad/featherpad-0.8.ebuild
parent4ecefdb170f4b1c7b7de25ad9f0b7b4535a387bb (diff)
app-editors/featherpad : version bump
Diffstat (limited to 'app-editors/featherpad/featherpad-0.8.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-0.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/featherpad/featherpad-0.8.ebuild b/app-editors/featherpad/featherpad-0.8.ebuild
new file mode 100644
index 00000000..4189920d
--- /dev/null
+++ b/app-editors/featherpad/featherpad-0.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils qmake-utils
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/FeatherPad-"${PV}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" fp.pro
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+}