summaryrefslogtreecommitdiff
path: root/app-editors/featherpad/featherpad-0.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-08 19:21:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-08 19:21:06 +0100
commitb99f1ebc5e3b0785d9ab9d517481f5138b8e258e (patch)
tree79770608f13dd8df469b52d8a4e3d781ebcde2bc /app-editors/featherpad/featherpad-0.9.1.ebuild
parentd4be3239b18ad7001f4bfc1825d1e85a1a79560b (diff)
app-editors/featherpad : version bump
Diffstat (limited to 'app-editors/featherpad/featherpad-0.9.1.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-0.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/featherpad/featherpad-0.9.1.ebuild b/app-editors/featherpad/featherpad-0.9.1.ebuild
new file mode 100644
index 00000000..4189920d
--- /dev/null
+++ b/app-editors/featherpad/featherpad-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils qmake-utils
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/FeatherPad-"${PV}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" fp.pro
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+}