summaryrefslogtreecommitdiff
path: root/app-editors/featherpad/featherpad-0.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 17:26:37 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 17:26:37 +0000
commit073121bf6a89d6d944e814a3dbc45f7edbc37d98 (patch)
treeb55357a3e173233a30d351039f9474d4c4502aa2 /app-editors/featherpad/featherpad-0.9.2.ebuild
parent13c3e29496465b6f48fed87b4d60de172b563c7e (diff)
app-editors/featherpad : version bump
Diffstat (limited to 'app-editors/featherpad/featherpad-0.9.2.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-0.9.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/featherpad/featherpad-0.9.2.ebuild b/app-editors/featherpad/featherpad-0.9.2.ebuild
new file mode 100644
index 00000000..4189920d
--- /dev/null
+++ b/app-editors/featherpad/featherpad-0.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils qmake-utils
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/FeatherPad-"${PV}"
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" fp.pro
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+}