summaryrefslogtreecommitdiff
path: root/app-editors/kakoune/kakoune-2019.01.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-15 14:20:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-15 14:20:59 +0100
commit7649637739caaf4271b23ea7d837ec51938ad4dd (patch)
tree82962ecbf84af828f5d30d4f0cb57b862c7f1493 /app-editors/kakoune/kakoune-2019.01.20.ebuild
parent69a7bd2b0e42314d80e89d4833a0f94284b5b4ba (diff)
app-editors/kakoune : new ebuild
Diffstat (limited to 'app-editors/kakoune/kakoune-2019.01.20.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2019.01.20.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2019.01.20.ebuild b/app-editors/kakoune/kakoune-2019.01.20.ebuild
new file mode 100644
index 00000000..6bf78bde
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2019.01.20.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs vcs-snapshot versionator
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://github.com/mawww/kakoune"
+SRC_URI="https://github.com/mawww/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]
+"
+DEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-gcc && ! version_is_at_least 5.0 $(gcc-version); then
+ die "Clang or GCC >=5.0 is required to build this version"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -i -e '/CXXFLAGS += -O3/d' src/Makefile || \
+ die "Failed to patch makefile"
+}
+
+src_configure() {
+ tc-export CXX
+ export debug=$(usex debug)
+ export static=$(usex static)
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" PREFIX="${EPREFIX}/usr" docdir="${ED%/}/usr/share/doc/${PF}" install
+}