summaryrefslogtreecommitdiff
path: root/dev-libs/libqtxdg/libqtxdg-3.12.0-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-15 18:44:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-15 18:44:44 +0100
commit56ff249d594640aa1015bcb8b04f34bdd4d7feaf (patch)
tree1304dc6757e63e6117bde0082d29e693c9f3ded0 /dev-libs/libqtxdg/libqtxdg-3.12.0-r5.ebuild
parentfda43397772811b92b0964a1f9619ad754c9360b (diff)
Revert "lxqt-base/lxqt-meta : support qt5 theming"
This reverts commit fda43397772811b92b0964a1f9619ad754c9360b.
Diffstat (limited to 'dev-libs/libqtxdg/libqtxdg-3.12.0-r5.ebuild')
-rw-r--r--dev-libs/libqtxdg/libqtxdg-3.12.0-r5.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-3.12.0-r5.ebuild b/dev-libs/libqtxdg/libqtxdg-3.12.0-r5.ebuild
deleted file mode 100644
index 6e69475a..00000000
--- a/dev-libs/libqtxdg/libqtxdg-3.12.0-r5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake optfeature virtualx
-
-DESCRIPTION="Qt Implementation of XDG Standards"
-HOMEPAGE="https://lxqt-project.org/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-fi
-
-LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
-SLOT="0/5"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=dev-util/lxqt-build-tools-0.13.0:${SLOT}
- virtual/pkgconfig
-"
-RDEPEND="
- dev-libs/glib:2
- >=dev-qt/qtcore-5.15:5
- >=dev-qt/qtdbus-5.15:5
- >=dev-qt/qtgui-5.15:5=
- >=dev-qt/qtsvg-5.15:5
- >=dev-qt/qtwidgets-5.15:5
- >=dev-qt/qtxml-5.15:5
- x11-misc/xdg-utils
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-qt/qttest-5.15:5 )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # Tests don't work with C
- LC_ALL=en_US.utf8 virtx cmake_src_test
-}
-
-pkg_postinst() {
- ! has_version lxqt-base/lxqt-meta && optfeature "features that require a terminal emulator" x11-terms/xterm
-}