summaryrefslogtreecommitdiff
path: root/dev-python/animation/animation-0.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 23:41:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 23:41:38 +0100
commit6e9f5a0ed97811bacfffb858ba09993b9a18dd30 (patch)
treeae443a2e5f6c76810b7a04517253581ef7d3638a /dev-python/animation/animation-0.0.5.ebuild
parent32426ea820fe85f4529ca7dcc1f3939536bb8045 (diff)
dev-python/animation : version bump
Diffstat (limited to 'dev-python/animation/animation-0.0.5.ebuild')
-rw-r--r--dev-python/animation/animation-0.0.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/animation/animation-0.0.5.ebuild b/dev-python/animation/animation-0.0.5.ebuild
new file mode 100644
index 00000000..a640a257
--- /dev/null
+++ b/dev-python/animation/animation-0.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for terminal-based wait animations"
+HOMEPAGE="https://github.com/bprinty/animation"
+SRC_URI="https://github.com/bprinty/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}