summaryrefslogtreecommitdiff
path: root/dev-python/wget/wget-2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-30 12:20:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-30 12:20:44 +0100
commit1304264d6db97d622783a1a3d6c9933e029e1dae (patch)
tree512ab2680ded6dd9cc21ecccd66c20b8da7edc20 /dev-python/wget/wget-2.2-r1.ebuild
parent1ca20f8af778c6f7b860fc093f779d63804e83a2 (diff)
parentb68bd360ef1c8817650e105f9c8187b82e428765 (diff)
Merge branch 'edge' into next
Diffstat (limited to 'dev-python/wget/wget-2.2-r1.ebuild')
-rw-r--r--dev-python/wget/wget-2.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/wget/wget-2.2-r1.ebuild b/dev-python/wget/wget-2.2-r1.ebuild
new file mode 100644
index 00000000..7590d4fd
--- /dev/null
+++ b/dev-python/wget/wget-2.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library for downloading from http URLs"
+HOMEPAGE="https://github.com/steveeJ/python-wget"
+
+EGIT_REPO_URI="https://github.com/steveeJ/python-wget.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}