summaryrefslogtreecommitdiff
path: root/dev-python/wget/wget-2.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 22:58:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 22:58:35 +0000
commit42afb19128a757e77cf212826a23aec5299053f6 (patch)
tree5b3acc9dd036ff394ef00af32facfd43dfa297b9 /dev-python/wget/wget-2.2-r3.ebuild
parent81ede220c13a4cced5b93a951604cde4e22bf0db (diff)
dev-python/{animation,sh,typer,wget} : EAPI bump
Diffstat (limited to 'dev-python/wget/wget-2.2-r3.ebuild')
-rw-r--r--dev-python/wget/wget-2.2-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/wget/wget-2.2-r3.ebuild b/dev-python/wget/wget-2.2-r3.ebuild
new file mode 100644
index 00000000..45a4ff1a
--- /dev/null
+++ b/dev-python/wget/wget-2.2-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_8,3_9,3_10} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library for downloading from http URLs"
+HOMEPAGE="https://github.com/steveeJ/python-wget"
+
+EGIT_REPO_URI="https://github.com/steveeJ/python-wget.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64 arm64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}