summaryrefslogtreecommitdiff
path: root/dev-qt/qtbluetooth/qtbluetooth-5.9.5-r1000.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-17 05:00:21 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-17 05:00:21 +0100
commit7eb78dbf89fda9dbc16848be08c9743bba5cf318 (patch)
tree65fcee0c54ea1966df0813594477d23f042f06cd /dev-qt/qtbluetooth/qtbluetooth-5.9.5-r1000.ebuild
parente98e69391231e8eb88b05a316e8181f2b8cc9a9b (diff)
"dev-qt : bump to 5.9.5"
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.9.5-r1000.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.9.5-r1000.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.9.5-r1000.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.9.5-r1000.ebuild
new file mode 100644
index 00000000..66bece29
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.9.5-r1000.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtconnectivity"
+inherit qt5-build-r10000
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtconcurrent-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdbus-${PV}
+ >=net-wireless/bluez-5:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtnetwork-${PV}
+"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build-r10000_src_prepare
+}