summaryrefslogtreecommitdiff
path: root/gnome-extra/gpaste/gpaste-3.8.ebuild
diff options
context:
space:
mode:
authorAlexe-Cristia Moldovan <contact@crism.ro>2015-06-18 15:14:58 +0300
committerAlexe-Cristia Moldovan <contact@crism.ro>2015-06-18 15:14:58 +0300
commit6c71fa52ceba4ae9e9b9258c8d3fd4edab905519 (patch)
treeb0e8aeacb72e86f71b1ef7e6ad691d2c20feca23 /gnome-extra/gpaste/gpaste-3.8.ebuild
parenta8da050bbbbe6352753c07b7b1d4753dbcf8eb7a (diff)
add gpaste - Clipboard management system
Diffstat (limited to 'gnome-extra/gpaste/gpaste-3.8.ebuild')
-rw-r--r--gnome-extra/gpaste/gpaste-3.8.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/gpaste/gpaste-3.8.ebuild b/gnome-extra/gpaste/gpaste-3.8.ebuild
new file mode 100644
index 00000000..abc5f9fc
--- /dev/null
+++ b/gnome-extra/gpaste/gpaste-3.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Clipboard management system"
+HOMEPAGE="http://github.com/Keruspe/GPaste"
+SRC_URI="http://www.imagination-land.org/files/gpaste//${P}.tar.xz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="applet bash-completion +gnome-shell +vala zsh-completion +systemd"
+
+DEPEND=">=dev-libs/glib-2.30:2
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=x11-libs/gtk+-3.0.0:3
+ dev-libs/libxml2
+ x11-libs/libxcb
+ sys-apps/dbus
+ >=dev-libs/gobject-introspection-1.30.0
+ >=dev-lang/vala-0.22.0:0.22[vapigen]"
+RDEPEND="${DEPEND}
+ bash-completion? ( app-shells/bash )
+ gnome-shell? ( >=gnome-base/gnome-shell-3.10 )
+ zsh-completion? ( app-shells/zsh app-shells/zsh-completion )
+ systemd? ( sys-apps/systemd )"
+
+G2CONF="
+ VALAC=$(type -p valac-0.22)
+ VAPIGEN=$(type -p vapigen-0.22)
+ --disable-schemas-compile
+ $(use_enable applet)
+ $(use_enable gnome-shell gnome-shell-extension)
+ $(use_enable vala)"
+
+
+REQUIRED_USE="|| ( gnome-shell applet )"
+
+src_configure(){
+ econf \
+ $(use_enable systemd)
+}
+
+src_install() {
+ use bash-completion && dobashcomp data/completions/gpaste
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins data/completions/_gpaste
+ fi
+ gnome2_src_install
+ find ${D} -name '*.la' -exec rm -f {} +
+}