summaryrefslogtreecommitdiff
path: root/gnome-extra/nautilus-file-roller/nautilus-file-roller-3.10.2.1.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:46:38 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:46:38 +0200
commit539ab2c329ef87cb855c5965a4e3995af9b1cad3 (patch)
treeeb48abd2bb1152d7a5a6e8e048d20f76b0057c9e /gnome-extra/nautilus-file-roller/nautilus-file-roller-3.10.2.1.ebuild
parentbf9f773fb3fcefed199cd8af38b65f77b347c80c (diff)
Added gnome already splitted ebuilds. will split later if needed to improve deps heaven
Diffstat (limited to 'gnome-extra/nautilus-file-roller/nautilus-file-roller-3.10.2.1.ebuild')
-rw-r--r--gnome-extra/nautilus-file-roller/nautilus-file-roller-3.10.2.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/nautilus-file-roller/nautilus-file-roller-3.10.2.1.ebuild b/gnome-extra/nautilus-file-roller/nautilus-file-roller-3.10.2.1.ebuild
new file mode 100644
index 00000000..e6ea7535
--- /dev/null
+++ b/gnome-extra/nautilus-file-roller/nautilus-file-roller-3.10.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+GNOME_ORG_MODULE="file-roller"
+inherit eutils gnome.org
+
+DESCRIPTION="Provides context menu for Nautilus"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ ~app-arch/file-roller-${PV}
+ >=gnome-base/nautilus-3
+"
+DEPEND=">=gnome-base/nautilus-3
+ >=dev-libs/glib-2.36.0:2
+ sys-devel/gettext
+ >=app-arch/libarchive-3:=
+ >=dev-libs/json-glib-0.14
+ virtual/pkgconfig
+ >=x11-libs/gtk+-3.9.3:3
+"
+
+src_configure() {
+ econf \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ --with-smclient=xsmp \
+ --enable-nautilus-actions \
+ --disable-packagekit \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ cd nautilus || die
+ emake
+}
+
+src_install() {
+ cd nautilus || die
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+}