summaryrefslogtreecommitdiff
path: root/mail-client/wmail/wmail-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-03-19 14:26:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-03-19 14:26:04 +0000
commitdf7fb536bab20640121c3c5ee68b8b1c7de7d083 (patch)
tree472a6a7c53978af768421211b2110665326dc390 /mail-client/wmail/wmail-2.3.0.ebuild
parent31a1b9e79a4d0cb5154ec4d8439ca24402890d0f (diff)
wmail : version bump
Diffstat (limited to 'mail-client/wmail/wmail-2.3.0.ebuild')
-rw-r--r--mail-client/wmail/wmail-2.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail-client/wmail/wmail-2.3.0.ebuild b/mail-client/wmail/wmail-2.3.0.ebuild
new file mode 100644
index 00000000..b2239c0a
--- /dev/null
+++ b/mail-client/wmail/wmail-2.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="The missing desktop client for Gmail & Google Inbox"
+HOMEPAGE="https://github.com/Thomas101/wmail"
+SRC_URI="https://github.com/Thomas101/wmail/releases/download/v${PV}/WMail_2_3_0_linux_x86_64.deb"
+
+LICENSE="GPL2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ gnome-base/gconf
+ media-libs/alsa-lib
+ sys-apps/lsb-release
+ x11-libs/gtk+:2
+ x11-libs/libXtst
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ mv * "${D}" || die
+ fperms 0755 /opt/${PN}-desktop/Wmail || die
+}