summaryrefslogtreecommitdiff
path: root/media-tv/sp-auth/sp-auth-3.2.6-r1.ebuild
diff options
context:
space:
mode:
authorStefan Cristian B. <steven.darklight@gmail.com>2014-11-14 19:42:43 +0200
committerStefan Cristian B. <steven.darklight@gmail.com>2014-11-14 19:42:43 +0200
commit931acec7b357a725c5bf20f898fbdf6ec69432c0 (patch)
tree53d388ef26a75f788a2d0752a9f51c3c4a071c22 /media-tv/sp-auth/sp-auth-3.2.6-r1.ebuild
parentc55ccebab3ea3eade7b44a5cf68f0173984af0e5 (diff)
parentc238e6e69c3eee178dbb7c071f4e661557c82a28 (diff)
Merge pull request #5 from V3n3RiX/master
convert sp-auth to multilib
Diffstat (limited to 'media-tv/sp-auth/sp-auth-3.2.6-r1.ebuild')
-rw-r--r--media-tv/sp-auth/sp-auth-3.2.6-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-tv/sp-auth/sp-auth-3.2.6-r1.ebuild b/media-tv/sp-auth/sp-auth-3.2.6-r1.ebuild
new file mode 100644
index 00000000..561ce7ae
--- /dev/null
+++ b/media-tv/sp-auth/sp-auth-3.2.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+MY_P="sp-sc-auth"
+
+DESCRIPTION="SopCast free P2P Internet TV binary"
+LICENSE="SopCast-unknown-license"
+HOMEPAGE="http://www.sopcast.com/"
+SRC_URI="http://sopcast-player.googlecode.com/files/${PN}-${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+# All dependencies might not be listed, since the binary blob's homepage only lists libstdc++
+RDEPEND="amd64? ( sys-libs/libstdc++-v3[multilib] )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ exeinto /usr/bin/
+ newexe sp-sc-auth ${MY_P} || die "newexe failed"
+ dodoc Readme || die "dodoc failed"
+}