summaryrefslogtreecommitdiff
path: root/media-tv/tv-maxe/tv-maxe-0.11-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-14 05:00:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-14 05:00:16 +0000
commit96cc2c341f6d72f20bbf3e3d0a964fb6915f6bc1 (patch)
tree433d2b4118840658dcca02bec5a5d403c4de84c6 /media-tv/tv-maxe/tv-maxe-0.11-r4.ebuild
parent51ae703665a2f42df0caaea717ae04d268d5ba5d (diff)
media-tv/tv-maxe : revision bump
Diffstat (limited to 'media-tv/tv-maxe/tv-maxe-0.11-r4.ebuild')
-rw-r--r--media-tv/tv-maxe/tv-maxe-0.11-r4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-tv/tv-maxe/tv-maxe-0.11-r4.ebuild b/media-tv/tv-maxe/tv-maxe-0.11-r4.ebuild
new file mode 100644
index 00000000..c86d395d
--- /dev/null
+++ b/media-tv/tv-maxe/tv-maxe-0.11-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Program to view free channels"
+HOMEPAGE="http://code.google.com/p/tv-maxe"
+SRC_URI="https://launchpad.net/~venerix/+archive/ubuntu/pkg/+files/${PN}_${PV}-0ubuntu2~trusty.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sqlite +vlc"
+
+DEPEND="dev-lang/python:2.7[sqlite]"
+RDEPEND="${DEPEND}
+ vlc? ( media-video/vlc )
+ dev-python/pillow
+ dev-python/python-virtkey
+ dev-python/pygtk
+ media-tv/sopcast
+ media-video/rtmpdump
+ virtual/ffmpeg"
+
+S="${WORKDIR}/${PN}-${PV}"
+
+src_prepare() {
+ epatch ${FILESDIR}/${PN}_disable_locale.patch
+ sed -i "s/python/python2/g" ${PN}/${PN}
+}
+
+src_install() {
+ dodir usr/bin
+ exeinto usr/bin
+ doexe ${PN}/${PN}
+
+ dodir usr/share/${PN}
+ insinto usr/share/${PN}
+ doins -r ${PN}/*
+
+ newicon ${PN}/tvmaxe_mini.png tv-maxe.png
+ make_desktop_entry tv-maxe TV-maxe \
+ "tv-maxe" \
+ AudioVideo
+}