summaryrefslogtreecommitdiff
path: root/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-14 23:40:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-14 23:40:58 +0100
commit7ef62fb13a69b652966b3df17b599ecc4ae308b9 (patch)
treeadf9685af1b8fdc3aab6d810d609813044806a5b /sys-auth/polkit-qt5/polkit-qt5-0.113.0-r10.ebuild
parent811d7f2bb22f413c47c1fd908c4c48b231f30a89 (diff)
sys-auth/polkit-qt : version bump
Diffstat (limited to 'sys-auth/polkit-qt5/polkit-qt5-0.113.0-r10.ebuild')
-rw-r--r--sys-auth/polkit-qt5/polkit-qt5-0.113.0-r10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r10.ebuild b/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r10.ebuild
new file mode 100644
index 00000000..7e85ce61
--- /dev/null
+++ b/sys-auth/polkit-qt5/polkit-qt5-0.113.0-r10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake kde.org
+
+DESCRIPTION="Qt wrapper around polkit-1 client libraries"
+HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
+ S="${WORKDIR}/${KDE_ORG_NAME}-${PV}"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ )
+
+ cmake_src_configure
+}