summaryrefslogtreecommitdiff
path: root/sys-boot/grubcfg/grubcfg-1337.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 22:53:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 22:53:55 +0000
commita3105a49ef1908bc17180973b007f895fb7e7603 (patch)
treec3e83d0457144a8ab5018c66fb737b7a92eb3969 /sys-boot/grubcfg/grubcfg-1337.ebuild
parent5a7d5559ad5ba62552db929d1347c472a798cfb8 (diff)
move : sys-boot/grub-config-redcore => sys-boot/grubcfg
Diffstat (limited to 'sys-boot/grubcfg/grubcfg-1337.ebuild')
-rw-r--r--sys-boot/grubcfg/grubcfg-1337.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-boot/grubcfg/grubcfg-1337.ebuild b/sys-boot/grubcfg/grubcfg-1337.ebuild
new file mode 100644
index 00000000..490e1933
--- /dev/null
+++ b/sys-boot/grubcfg/grubcfg-1337.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Redcore Linux GRUB configuration files"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${FILESDIR}"
+
+src_install() {
+ dodir "etc/default" || die
+ insinto "etc/default" || die
+ newins grub grub.example || die
+}
+
+pkg_preinst() {
+ if [[ -f ""${ROOT}"etc/default/grub" ]]; then
+ mv ""${ROOT}"etc/default/grub" ""${ROOT}"etc/default/grub.bak"
+ fi
+}
+
+pkg_postinst() {
+ if [[ -f ""${ROOT}"etc/default/grub.bak" ]]; then
+ mv ""${ROOT}"etc/default/grub.bak" ""${ROOT}"etc/default/grub"
+ fi
+}