summaryrefslogtreecommitdiff
path: root/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2015-01-31 17:28:36 +0200
committerBlackNoxis <steven.darklight@gmail.com>2015-01-31 17:28:36 +0200
commitc10e19fb40f1bec5f9341dbbb7a238432adc6f74 (patch)
treeed27a72a3833014cc0c6fdf5fb5282a934b38999 /x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild
parent986aa85f934aeba29adffe4acf1afb7b445aa14f (diff)
Added lightdm greeter
Diffstat (limited to 'x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild')
-rw-r--r--x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild b/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild
new file mode 100644
index 00000000..be818c54
--- /dev/null
+++ b/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit versionator
+
+DESCRIPTION="LightDM GTK+ Greeter"
+HOMEPAGE="http://launchpad.net/lightdm-gtk-greeter"
+SRC_URI="http://launchpad.net/lightdm-gtk-greeter/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+# This ebuild needs custom Sabayon themes, thus it must depend on sabayon-artwork-core
+DEPEND="x11-libs/gtk+:3
+ >=x11-misc/lightdm-1.2.2"
+RDEPEND="!!<x11-misc/lightdm-1.1.1
+ app-admin/eselect-lightdm
+ x11-libs/gtk+:3
+ >=x11-misc/lightdm-1.2.2
+ x11-themes/gnome-themes-standard
+ x11-themes/gnome-icon-theme
+ x11-themes/sabayon-artwork-core"
+
+src_prepare() {
+ # Apply custom Sabayon theme
+ sed -i \
+ -e 's:#background=.*:background=/usr/share/backgrounds/kgdm.png:' \
+ -e 's:#xft-hintstyle=.*:xft-hintstyle=hintfull:' \
+ -e 's:#xft-antialias=.*:xft-antialias=true:' \
+ -e 's:#xft-rgba=.*:xft-rgba=rgb:' "data/${PN}.conf" || die
+}
+
+pkg_postinst() {
+ # Make sure to have a greeter properly configured
+ eselect lightdm set lightdm-gtk-greeter --use-old
+}
+
+pkg_postrm() {
+ eselect lightdm set 1 # hope some other greeter is installed
+}