summaryrefslogtreecommitdiff
path: root/x11-terms/cool-retro-term/cool-retro-term-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-08 10:34:43 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-08 10:34:43 +0000
commitdbf5f90161123582ebf9b9ef50f21bcb82a88011 (patch)
treee5b6f62f8ce24eafc2c7dbaf946a3b06b15a78f4 /x11-terms/cool-retro-term/cool-retro-term-1.1.1.ebuild
parent5d5b302b12f7d1ccfc7a873a290f8ab3ab914052 (diff)
x11-terms/cool-retro-term : new package
Diffstat (limited to 'x11-terms/cool-retro-term/cool-retro-term-1.1.1.ebuild')
-rw-r--r--x11-terms/cool-retro-term/cool-retro-term-1.1.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-terms/cool-retro-term/cool-retro-term-1.1.1.ebuild b/x11-terms/cool-retro-term/cool-retro-term-1.1.1.ebuild
new file mode 100644
index 00000000..ff951cab
--- /dev/null
+++ b/x11-terms/cool-retro-term/cool-retro-term-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2016-2019 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils qmake-utils git-r3
+
+DESCRIPTION="A good looking terminal emulator which mimics the old cathode display"
+HOMEPAGE="https://github.com/Swordfish90/"
+LICENSE="GPL-2"
+
+EGIT_REPO_URI="${HOMEPAGE}${PN}.git"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[localstorage]
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ git-r3_fetch ${EGIT_REPO_URI} refs/tags/${PV} || die
+ git-r3_checkout || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr" ${PN}.pro || die
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+}