summaryrefslogtreecommitdiff
path: root/x11-themes/material-icon-theme/material-icon-theme-1.314.1337-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-19 12:39:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-19 12:39:37 +0100
commit279a651a3c5f53d8e1581e0ffb0542ba8842e96a (patch)
tree9b87a125e7c9950102122dde28ef8768fea0f3b7 /x11-themes/material-icon-theme/material-icon-theme-1.314.1337-r2.ebuild
parent8ff547d15172cf77ceae53b4dba6fbb894e9b61e (diff)
x11-themes/material-icon-theme : migrate from gnome2-utils to xdg-utils eclass
Diffstat (limited to 'x11-themes/material-icon-theme/material-icon-theme-1.314.1337-r2.ebuild')
-rw-r--r--x11-themes/material-icon-theme/material-icon-theme-1.314.1337-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/material-icon-theme/material-icon-theme-1.314.1337-r2.ebuild b/x11-themes/material-icon-theme/material-icon-theme-1.314.1337-r2.ebuild
new file mode 100644
index 00000000..29a71285
--- /dev/null
+++ b/x11-themes/material-icon-theme/material-icon-theme-1.314.1337-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 xdg-utils
+
+DESCRIPTION="Icon theme following the Google's material design specifications"
+HOMEPAGE="https://gitlab.com/bionel/bionel-icons"
+
+EGIT_BRANCH="master"
+EGIT_REPO_URI="https://gitlab.com/bionel/bionel-icons.git"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_install() {
+ dodir usr/share/icons
+ insinto usr/share/icons
+ doins -r material-icons/*
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}