summaryrefslogtreecommitdiff
path: root/x11-themes/numix-gtk-theme-dark/numix-gtk-theme-dark-2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@rogentos.ro>2015-03-15 16:41:13 +0200
committerV3n3RiX <venerix@rogentos.ro>2015-03-15 16:41:13 +0200
commit09ca1b97d864cc77b7dd704e36fd4e7a139c6db2 (patch)
treee297a3e00670ab619f89d31a7cf9a9e07690ab25 /x11-themes/numix-gtk-theme-dark/numix-gtk-theme-dark-2.4.ebuild
parente8a390d049832e3517680210c5517b2c678c1901 (diff)
proper ebuild for numix theme + patched dark variant
Diffstat (limited to 'x11-themes/numix-gtk-theme-dark/numix-gtk-theme-dark-2.4.ebuild')
-rw-r--r--x11-themes/numix-gtk-theme-dark/numix-gtk-theme-dark-2.4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-themes/numix-gtk-theme-dark/numix-gtk-theme-dark-2.4.ebuild b/x11-themes/numix-gtk-theme-dark/numix-gtk-theme-dark-2.4.ebuild
new file mode 100644
index 00000000..6feb78f9
--- /dev/null
+++ b/x11-themes/numix-gtk-theme-dark/numix-gtk-theme-dark-2.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+MY_P="numix-gtk-theme"
+MY_PN="NumixDark"
+
+DESCRIPTION="Numix GTK Theme"
+HOMEPAGE="https://numixproject.org/"
+SRC_URI="https://launchpad.net/~numix/+archive/ubuntu/ppa/+files/${MY_P}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+gtk3 metacity openbox unity xfwm4"
+
+DEPEND=""
+RDEPEND="x11-themes/gtk-engines-murrine
+ gtk3? ( x11-themes/gtk-engines-unico )"
+
+S="${WORKDIR}/${MY_P}-${PV}"
+
+src_prepare() {
+ epatch -p1 "${FILESDIR}/dark.patch"
+}
+
+src_install() {
+ cd "${S}"
+ dodir /usr/share/themes/${MY_PN}
+ insinto /usr/share/themes/${MY_PN}
+ doins -r "${S}"/*
+
+ use gtk3 || {
+ rm -R "${D}"/usr/share/themes/*/gtk-3.0 || die
+ }
+
+ use metacity || {
+ rm -R "${D}"/usr/share/themes/*/metacity-1 || die
+ }
+
+ use openbox || {
+ rm -R "${D}"/usr/share/themes/*/openbox-3 || die
+ }
+
+ use unity || {
+ rm -R "${D}"/usr/share/themes/*/unity || die
+ }
+
+ use xfwm4 || {
+ rm -R "${D}"/usr/share/themes/*/xfwm4 || die
+ }
+
+}