summaryrefslogtreecommitdiff
path: root/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild')
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
new file mode 100644
index 00000000..2f1397b4
--- /dev/null
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="ICU Layout Engine API on top of HarfBuzz shaping library"
+HOMEPAGE="http://www.harfbuzz.org https://github.com/behdad/icu-le-hb"
+SRC_URI="https://github.com/behdad/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+
+KEYWORDS="amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/harfbuzz:=[${MULTILIB_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/icu-58.1[${MULTILIB_USEDEP}]
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf
+}