summaryrefslogtreecommitdiff
path: root/dev-libs/satyr/satyr-0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/satyr/satyr-0.13.ebuild')
-rw-r--r--dev-libs/satyr/satyr-0.13.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/satyr/satyr-0.13.ebuild b/dev-libs/satyr/satyr-0.13.ebuild
new file mode 100644
index 00000000..031b9a6f
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils autotools python-single-r1 toolchain-funcs
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://fedorahosted.org/released/abrt/satyr-${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ app-arch/rpm
+ >=dev-libs/elfutils-0.158"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/satyr-0.13-elfutils-0.158.patch"
+
+ default
+}
+
+src_configure() {
+ econf --disable-python-manpage --disable-static
+}