summaryrefslogtreecommitdiff
path: root/dev-python/python-report/python-report-0.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-report/python-report-0.10-r1.ebuild')
-rw-r--r--dev-python/python-report/python-report-0.10-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/python-report/python-report-0.10-r1.ebuild b/dev-python/python-report/python-report-0.10-r1.ebuild
deleted file mode 100644
index cd4a57b6..00000000
--- a/dev-python/python-report/python-report-0.10-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="3"
-
-EGIT_REPO_URI="git://git.fedorahosted.org/report.git"
-EGIT_COMMIT="${PV}"
-inherit base git-2 autotools eutils
-
-DESCRIPTION="Provides a single configurable problem/bug/issue reporting API."
-HOMEPAGE="http://git.fedoraproject.org/git/?p=report.git;a=summary"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="app-arch/rpm
- net-misc/curl"
-RDEPEND="dev-libs/openssl
- net-misc/curl
- dev-libs/libxml2"
-
-src_prepare() {
-
- epatch "${FILESDIR}"/${P}-kogaion-defaults.patch
- epatch "${FILESDIR}"/${P}-disable-rpm.patch
- epatch "${FILESDIR}"/${P}-fix-version-detection.patch
-
- eautoreconf || die "cannot run eautoreconf"
- autoreconf -i || die "wtf"
- eautomake || die "cannot run eautomake"
-}
-
-src_configure() {
- econf --prefix=/usr || die "configure failed"
-}
-
-src_compile() {
- # workaround crappy build system
- mkdir -p "${S}/python/report/templates/RHEL-template/bugzillaCopy"
- touch "${S}/python/report/templates/RHEL-template/bugzillaCopy/VERSION"
-
- emake || die "make failed"
-}
-
-src_install() {
- base_src_install
-
- # remove Red Hat stuff
- rm "${D}"/etc/report.d/RHEL.ini
- rm "${D}"/etc/report.d/dropbox.redhat.com.ini
- rm "${D}"/etc/report.d/bugzilla.redhat.com.ini
-
- # XXX: {not yet implemented} install Kogaion configuration
- # cp "${FILESDIR}"/bugs.rogentos.ro.ini "${D}/etc/report.d/"
- find "${D}"/ -name "bugzilla-template" -type d | xargs rm -rf
- find "${D}"/ -name "RHEL-template" -type d | xargs rm -rf
- find "${D}"/ -name "strata-template" -type d | xargs rm -rf
-
-}