summaryrefslogtreecommitdiff
path: root/kde-base/oxygen-icons/oxygen-icons-4.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/oxygen-icons/oxygen-icons-4.12.1.ebuild')
-rw-r--r--kde-base/oxygen-icons/oxygen-icons-4.12.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/oxygen-icons/oxygen-icons-4.12.1.ebuild b/kde-base/oxygen-icons/oxygen-icons-4.12.1.ebuild
new file mode 100644
index 00000000..c06bdce4
--- /dev/null
+++ b/kde-base/oxygen-icons/oxygen-icons-4.12.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+if [[ ${PV} == *9999 ]]; then
+ KMNAME="kdesupport"
+fi
+KDE_REQUIRED="never"
+KDE_SCM="svn"
+inherit kde4-base
+
+SLREV=4
+DESCRIPTION="Oxygen SVG icon theme."
+HOMEPAGE="http://www.oxygen-icons.org/"
+[[ ${PV} == *9999 ]] || \
+SRC_URI="
+ !bindist? ( http://dev.gentoo.org/~dilfrigde/distfiles/${P}.repacked.tar.xz )
+ mirror://sabayon/x11-themes/fdo-icons-sabayon${SLREV}.tar.gz
+ bindist? ( ${SRC_URI} )
+"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="aqua bindist"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ kde4-base_src_prepare
+ cp -r "${WORKDIR}"/fdo-icons-sabayon/* "${S}" || die
+}