summaryrefslogtreecommitdiff
path: root/net-im/telegram-purple/telegram-purple-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telegram-purple/telegram-purple-9999.ebuild')
-rw-r--r--net-im/telegram-purple/telegram-purple-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/telegram-purple/telegram-purple-9999.ebuild b/net-im/telegram-purple/telegram-purple-9999.ebuild
new file mode 100644
index 00000000..d0f182b3
--- /dev/null
+++ b/net-im/telegram-purple/telegram-purple-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-r3
+
+DESCRIPTION="Libpurple (Pidgin) plugin for using a Telegram account"
+HOMEPAGE="https://github.com/majn/${PN}"
+SRC_URI=""
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="net-im/pidgin
+ dev-libs/openssl
+ sys-libs/glibc
+ "
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst(){
+ elog "Note: this package is in an early (pre-alpha) stage, so if you"
+ elog "want to view changes, install this package often."
+ elog "More information is available in ${HOMEPAGE}"
+}