summaryrefslogtreecommitdiff
path: root/net-misc/haguichi/haguichi-1.0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/haguichi/haguichi-1.0.13.ebuild')
-rw-r--r--net-misc/haguichi/haguichi-1.0.13.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/haguichi/haguichi-1.0.13.ebuild b/net-misc/haguichi/haguichi-1.0.13.ebuild
new file mode 100644
index 00000000..d6e7184f
--- /dev/null
+++ b/net-misc/haguichi/haguichi-1.0.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+DESCRIPTION="LogMeIn Hamachi VPN GUI Client"
+HOMEPAGE="http://www.haguichi.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+dev-lang/mono
+net-misc/logmein-hamachi
+dev-dotnet/gtk-sharp
+dev-dotnet/notify-sharp
+dev-dotnet/gconf-sharp
+dev-dotnet/ndesk-dbus
+dev-dotnet/ndesk-dbus-glib
+kde-base/dolphin
+kde-base/konsole
+kde-base/krdc
+"
+SRC_URI="http://launchpad.net/haguichi/1.0/1.0.13/+download/haguichi-1.0.13-clr4.0.tar.gz"
+IUSE=""
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_test(){
+ emake check || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "install failed"
+ /etc/init.d/logmein-hamachi restart
+}
+