summaryrefslogtreecommitdiff
path: root/net-p2p/gnunet-qt/gnunet-qt-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gnunet-qt/gnunet-qt-0.8.1.ebuild')
-rw-r--r--net-p2p/gnunet-qt/gnunet-qt-0.8.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/gnunet-qt/gnunet-qt-0.8.1.ebuild b/net-p2p/gnunet-qt/gnunet-qt-0.8.1.ebuild
new file mode 100644
index 00000000..4990812a
--- /dev/null
+++ b/net-p2p/gnunet-qt/gnunet-qt-0.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils multilib qt4-r2
+
+DESCRIPTION="QT Graphical front end for GNUnet."
+HOMEPAGE="http://www.gnunet.org/"
+SRC_URI="http://gnunet.org/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/qt-gui:4
+ >=net-p2p/gnunet-${PV}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --with-gnunet=/usr || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+# cd "${S}"/Qt${myqtver}
+# eqmake${myqtver} qscintilla.pro
+#
+# cd "${S}"/designer-Qt${myqtver}
+# eqmake${myqtver} designer.pro
+#}
+
+#src_compile() {
+# cd "${S}"/Qt${myqtver}
+# emake all staticlib || die "emake failed"
+#
+# cd "${S}"/designer-Qt${myqtver}
+# emake || die "failed to build designer plugin"
+#}
+
+#src_install() {
+# emake INSTALL_ROOT="${D}" install || die "designer plugin installation failed"
+# dodoc ChangeLog NEWS
+#}