summaryrefslogtreecommitdiff
path: root/sys-devel/gcc/gcc-10.3.0-r10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-10.3.0-r10.ebuild')
-rw-r--r--sys-devel/gcc/gcc-10.3.0-r10.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-10.3.0-r10.ebuild b/sys-devel/gcc/gcc-10.3.0-r10.ebuild
new file mode 100644
index 00000000..2d3e3739
--- /dev/null
+++ b/sys-devel/gcc/gcc-10.3.0-r10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PATCH_VER="1"
+
+inherit toolchain
+
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND=""
+BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ if has_version '>=sys-libs/glibc-2.32-r1'; then
+ rm -v "${WORKDIR}/patch/23_all_disable-riscv32-ABIs.patch" || die
+ fi
+
+ toolchain_src_prepare
+}