summaryrefslogtreecommitdiff
path: root/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.0-r1.ebuild')
-rw-r--r--xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.0-r1.ebuild b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.0-r1.ebuild
new file mode 100644
index 00000000..32eb7e73
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-appfinder/xfce4-appfinder-4.10.0-r1.ebuild,v 1.10 2013/04/13 07:19:50 ago Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfconf-4.10
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-null-pointers.patch
+ "${FILESDIR}"/${P}-icon-theme-segfault.patch
+ )
+
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS )
+}