# Copyright 2004-2014 Sabayon
# Copyright 2014 Kogaion
# Distributed under the terms of the GNU General Public License v2

EAPI=5

EGIT_REPO_URI="git://github.com/Rogentos/kogaion-live.git"
#EGIT_COMMIT="v${PV}"

inherit eutils systemd git-2

DESCRIPTION="Kogaion live image scripts and tools"
HOMEPAGE="http://www.rogentos.ro"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 arm x86"
IUSE=""

DEPEND=""
RDEPEND="!app-misc/livecd-tools
	app-eselect/eselect-opengl
	dev-util/dialog
	sys-apps/gawk
	sys-apps/pciutils
	sys-apps/keyboard-configuration-helpers
	sys-apps/sed"

src_install() {
	emake DESTDIR="${D}" SYSTEMD_UNITDIR="$(systemd_get_unitdir)" \
		install || die
}

pkg_postrm() {
	for service in "x-setup.service" "cdeject.service" "installer-text.service" "installer-gui.service" "graphical_start.service" "kogaionlive.service" ; do
		find "${ROOT}etc/systemd/system" -name "$service" -delete
	done
}