# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="amd64"

DESCRIPTION="Qt port of libfm, a library providing components to build desktop file managers"
HOMEPAGE="http://lxqt.org/"

LICENSE="LGPL-2.1+"
SLOT="0/5"

PATCHES=(
	"${FILESDIR}/${P}-check-if-app-exists-before-opening.patch"
	"${FILESDIR}/${P}-fix-smb-error.patch"
	"${FILESDIR}/${P}-correctly-handle-mountable-types.patch"
)

RDEPEND="
	dev-libs/glib:2
	dev-qt/qtcore:5
	dev-qt/qtgui:5
	dev-qt/qtwidgets:5
	dev-qt/qtx11extras:5
	>=lxde-base/menu-cache-0.4.1
	>=x11-libs/libfm-1.3.0:=
	x11-libs/libxcb:="
DEPEND="${RDEPEND}
	dev-qt/linguist-tools:5
	>=lxqt-base/liblxqt-0.13.0
	virtual/pkgconfig
"

src_configure() {
	local mycmakeargs=(
		-DPULL_TRANSLATIONS=NO
	)

	cmake-utils_src_configure
}