summaryrefslogtreecommitdiff
path: root/app-shells/dsh/dsh-0.25.10-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/dsh/dsh-0.25.10-r2.ebuild')
-rw-r--r--app-shells/dsh/dsh-0.25.10-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/dsh/dsh-0.25.10-r2.ebuild b/app-shells/dsh/dsh-0.25.10-r2.ebuild
new file mode 100644
index 000000000000..40cc257b9efd
--- /dev/null
+++ b/app-shells/dsh/dsh-0.25.10-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Distributed Shell"
+HOMEPAGE="http://www.netfort.gr.jp/~dancer/software/dsh.html.en"
+SRC_URI="http://www.netfort.gr.jp/~dancer/software/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls"
+
+DEPEND="dev-libs/libdshconfig"
+RDEPEND="${DEPEND}
+ virtual/ssh
+"
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/dsh
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodir /etc/dsh/group
+}