summaryrefslogtreecommitdiff
path: root/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild')
-rw-r--r--dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild b/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild
index 171554c2aebe..6f2ba7ca3b89 100644
--- a/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild
+++ b/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -93,6 +93,10 @@ src_configure() {
filter-flags -fprefetch-loop-arrays
filter-mfpmath sse
+ # bug #917662, bug #924659
+ filter-lto
+ append-flags -fno-strict-aliasing $(test-flags-CXX -fno-lifetime-dse)
+
# otherwise this doesnt build with gcc-6
# http://tracker.firebirdsql.org/browse/CORE-5099
append-cflags -fno-sized-deallocation -fno-delete-null-pointer-checks