summaryrefslogtreecommitdiff
path: root/dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.390.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.390.0.ebuild')
-rw-r--r--dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.390.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.390.0.ebuild b/dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.390.0.ebuild
new file mode 100644
index 000000000000..fe0b317ad2a3
--- /dev/null
+++ b/dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.390.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ARFREITAS
+DIST_VERSION=0.39
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="API wrapper around the 'tar' utility"
+LICENSE="GPL-3+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# r:Cwd -> File-Spec
+RDEPEND="
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/File-Which
+ dev-perl/IPC-Run
+ dev-perl/Log-Log4perl
+ virtual/perl-File-Path
+ app-arch/tar
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-CPAN-Meta
+ test? (
+ >=virtual/perl-Test-Simple-1.302.73
+ )
+"