summaryrefslogtreecommitdiff
path: root/dev-perl/PDF-API2/PDF-API2-2.45.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/PDF-API2/PDF-API2-2.45.0.ebuild')
-rw-r--r--dev-perl/PDF-API2/PDF-API2-2.45.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/PDF-API2/PDF-API2-2.45.0.ebuild b/dev-perl/PDF-API2/PDF-API2-2.45.0.ebuild
new file mode 100644
index 000000000000..a365658ed78a
--- /dev/null
+++ b/dev-perl/PDF-API2/PDF-API2-2.45.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SSIMMS
+DIST_VERSION=2.045
+DIST_EXAMPLES=( "contrib/*" )
+inherit perl-module
+
+DESCRIPTION="Facilitates the creation and modification of PDF files"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=virtual/perl-IO-Compress-1.0.0
+ dev-perl/Font-TTF
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Memory-Cycle
+ )
+"
+
+src_test() {
+ perl_rm_files t/author-*.t
+ perl-module_src_test
+}