summaryrefslogtreecommitdiff
path: root/dev-perl/Tie-Cycle/Tie-Cycle-1.228.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Tie-Cycle/Tie-Cycle-1.228.0.ebuild')
-rw-r--r--dev-perl/Tie-Cycle/Tie-Cycle-1.228.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Tie-Cycle/Tie-Cycle-1.228.0.ebuild b/dev-perl/Tie-Cycle/Tie-Cycle-1.228.0.ebuild
new file mode 100644
index 000000000000..95116737aaff
--- /dev/null
+++ b/dev-perl/Tie-Cycle/Tie-Cycle-1.228.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=BDFOY
+DIST_VERSION=1.228
+inherit perl-module
+
+DESCRIPTION="Cycle through a list of values via a scalar"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ virtual/perl-File-Spec
+ test? (
+ >=virtual/perl-Test-Simple-0.950.0
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.225-nopodtests.patch" )
+
+PERL_RM_FILES=( "t/pod.t" "t/pod_coverage.t" )