summaryrefslogtreecommitdiff
path: root/acct-user/octoprint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /acct-user/octoprint
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'acct-user/octoprint')
-rw-r--r--acct-user/octoprint/Manifest2
-rw-r--r--acct-user/octoprint/metadata.xml8
-rw-r--r--acct-user/octoprint/octoprint-0.ebuild15
3 files changed, 25 insertions, 0 deletions
diff --git a/acct-user/octoprint/Manifest b/acct-user/octoprint/Manifest
new file mode 100644
index 000000000000..702ecd9af346
--- /dev/null
+++ b/acct-user/octoprint/Manifest
@@ -0,0 +1,2 @@
+EBUILD octoprint-0.ebuild 310 BLAKE2B c11936e7de754495f7e88e623c47c7d0125b530ad020cf051a1d80f41222f732f6657943edc0182aa0b579d4654f5288bc7b2538022ce4b165db9e4448f5fc49 SHA512 775de41ba924e8620a6ca5cd05c0bca77837fb5bfa7673dffdc7243a6024b4b11da8765a3f01740edfe634ec58ba8ba9afbd3c17b92115ce93f95d753df64198
+MISC metadata.xml 272 BLAKE2B fc647f1c3bd36da8740de72e83af1e2c0c49977e4d43b06a92753bf4a64a3363b703988a42fc456dae2083ead884eb0c2a2a67f659f33e4bac59eb2ff877a88d SHA512 c2000525052c492949e2f9332c45cc0ce64a2472583d52ba301ce688d03009b92a69490a2cf8eb22aeec7b1ff6fdcf552dc2c434e4e3948abea2952f45751316
diff --git a/acct-user/octoprint/metadata.xml b/acct-user/octoprint/metadata.xml
new file mode 100644
index 000000000000..c7421e98fb6a
--- /dev/null
+++ b/acct-user/octoprint/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo Packages for 3d printing</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/octoprint/octoprint-0.ebuild b/acct-user/octoprint/octoprint-0.ebuild
new file mode 100644
index 000000000000..90468370d88b
--- /dev/null
+++ b/acct-user/octoprint/octoprint-0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for OctoPrint"
+
+ACCT_USER_ID=368
+ACCT_USER_HOME=/var/lib/octoprint
+ACCT_USER_HOME_OWNER=octoprint:octoprint
+ACCT_USER_GROUPS=( octoprint video )
+
+acct-user_add_deps