summaryrefslogtreecommitdiff
path: root/app-accessibility/eflite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-accessibility/eflite
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-accessibility/eflite')
-rw-r--r--app-accessibility/eflite/Manifest6
-rw-r--r--app-accessibility/eflite/eflite-0.4.1-r3.ebuild45
-rw-r--r--app-accessibility/eflite/files/eflite-0.4.1-flite14.patch24
-rw-r--r--app-accessibility/eflite/files/eflite.rc28
-rw-r--r--app-accessibility/eflite/files/es.conf11
-rw-r--r--app-accessibility/eflite/metadata.xml33
6 files changed, 147 insertions, 0 deletions
diff --git a/app-accessibility/eflite/Manifest b/app-accessibility/eflite/Manifest
new file mode 100644
index 000000000000..c1ed9a56f337
--- /dev/null
+++ b/app-accessibility/eflite/Manifest
@@ -0,0 +1,6 @@
+AUX eflite-0.4.1-flite14.patch 1070 BLAKE2B 18faef8ed5fe227a060c33f82a8dae1cca5282da77b152297040fb601722d4e9f7017758fa0fcf0c2d94bc9e79cc3f0e8e5869756ea9e30be694b86c5561419b SHA512 fabf260a517c1d7fd3af66fd6972f200d9c7d129ed36090ae77f493142728cd6207db77b1b02710fd22fd0e81e59857fb21b113ef5fb30ff6035778e143a3304
+AUX eflite.rc 645 BLAKE2B af3a7b34248ce59d74d3906934083f65f6c8bc9ae1398ebd2437f038ceac8058241e96825ccc51d22a58bacb3cee3bfe7961e75fa02ce31f396356329a142ef8 SHA512 81a918cc412500ed2ccd15eede7c2e800d6a0c04916b0e86e490027543430c8c0bd84b0e0d28280d4b22f3def37d8f94cfb0ad1d1df1446650c17f8bcbe7b7ca
+AUX es.conf 213 BLAKE2B 69a936177c702eab79454f2c17d764ffa508e518abc4576eb18557f925976eb659e0f30d4a59e734525f3167fcfdd5c4967db58af60a30dc7845f5d2cd182ef2 SHA512 19e8b5aefb7aa650d1e023a8cd5cf7361acf6f390f2f3f34de1da0b9c2bdddf632bc247f4e6c8eac025118c76d64f375837c13aff8f02342f17acc974beb9547
+DIST eflite-0.4.1.tar.gz 63192 BLAKE2B 4bdd8bf689732ac56918cefc42d9443ce09d27db052f218c34d7e6b2734e12835482b5c3e3e99f9e2cfe9d1645f683e67aec1ecdbc00c8967637d65d59fd14e3 SHA512 0060980fd5bb65ad94f1609f6d87cb89b91e680228b603fa590e6ba70b51e894493dda4271dca4d8c97f38cdefbd456c3be0447e5f88a0be7ae39324baa2c796
+EBUILD eflite-0.4.1-r3.ebuild 925 BLAKE2B 8ae762568b882ee2002017aa3ac902bd0eb445952497132226ddf9ee37bfbe21472222b858de2cf5705e0bd059e12dde2787a4d845b348cf818cad7303404de8 SHA512 40ddda73dc2d7f34dbadcd4894e408cf73c4a29054061d50cf82bad32a3c5aa26e58af2820f25022358450735a395b2a40c2f4ee8a76b630027cab43b36319df
+MISC metadata.xml 1230 BLAKE2B 903c52279480c3aa7b93f79b2b08be0288d4006962e9fac60655a0c3087287080f63d42f254bbe6b4a31488c1212a429eafc44c17bb2b22679192c103567b8b1 SHA512 12e9252ad64880f82a2c030444f2ead9139a5762d482e8cb7a0b3d19d3a9abc9039dc31aae988dcbc11d682b3135a0a7fab8e0699eb8d7a06d2b5ea0a3d3e4d3
diff --git a/app-accessibility/eflite/eflite-0.4.1-r3.ebuild b/app-accessibility/eflite/eflite-0.4.1-r3.ebuild
new file mode 100644
index 000000000000..fd08c28eb243
--- /dev/null
+++ b/app-accessibility/eflite/eflite-0.4.1-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+inherit autotools eutils user
+
+DESCRIPTION="A speech server that allows screen readers to interact with festival lite"
+HOMEPAGE="http://eflite.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE="+16k_voice"
+
+DEPEND=">=app-accessibility/flite-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's:/etc/es.conf:/etc/eflite/es.conf:g' *
+ epatch "${FILESDIR}"/${PN}-0.4.1-flite14.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use 16k_voice; then
+ myconf='--with-vox=cmu_us_kal16'
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ einstall
+ dodoc ChangeLog README INSTALL eflite_test.txt
+
+ insinto /etc/eflite
+ doins "${FILESDIR}"/es.conf
+
+ newinitd "${FILESDIR}"/eflite.rc eflite
+}
+
+pkg_postinst() {
+ enewgroup speech
+}
diff --git a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
new file mode 100644
index 000000000000..cb3096d88a43
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
@@ -0,0 +1,24 @@
+diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
+--- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
++++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
+@@ -34,7 +34,7 @@
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
+
+ fs.o: fs.c
+- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
++ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
+
+ tone.o: tone.c
+ $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<
+diff -Naur eflite-0.4.1/fs.c eflite-0.4.1.new/fs.c
+--- eflite-0.4.1/fs.c 2007-01-18 16:01:09.000000000 -0800
++++ eflite-0.4.1.new/fs.c 2013-09-08 09:31:57.417262688 -0700
+@@ -523,7 +523,7 @@
+ int playlen, skip;
+ if (type == SPEECH)
+ {
+- skip = (187 * wptr->sample_rate) / speed;
++ skip = 0;
+ playlen = wptr->num_samples - (skip * 2);
+ if (playlen > 0 && playlen < 500) playlen += (skip * 2) / 3;
+ }
diff --git a/app-accessibility/eflite/files/eflite.rc b/app-accessibility/eflite/files/eflite.rc
new file mode 100644
index 000000000000..2a65b04d0a8a
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite.rc
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use alsasound
+ use modules
+ use hotplug
+}
+
+start() {
+ ebegin "Starting eflite"
+ start-stop-daemon --start --exec /usr/bin/eflite --background \
+ --quiet --pidfile /var/run/eflite.pid --make-pidfile -- -D || eend 1
+
+ SOCKET=`egrep '^sockname=' /etc/eflite/es.conf | sed 's/^sockname=//'`
+ [ ! -S ${SOCKET} ] && SOCKET=/tmp/es.socket
+
+ chown root:speech ${SOCKET}
+ chmod 660 ${SOCKET}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eflite"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eflite.pid
+ eend $?
+}
diff --git a/app-accessibility/eflite/files/es.conf b/app-accessibility/eflite/files/es.conf
new file mode 100644
index 000000000000..17443d3e42ba
--- /dev/null
+++ b/app-accessibility/eflite/files/es.conf
@@ -0,0 +1,11 @@
+# What socket do we listen on
+sockname=/tmp/es.socket
+
+# What volume do we set?
+tone_volume=8192
+
+# Do we use the PC Speaker? (0/1)
+speaker_tones=0
+
+# Do we use the sound card (via flite)? (0/1)
+soundcard_tones=1
diff --git a/app-accessibility/eflite/metadata.xml b/app-accessibility/eflite/metadata.xml
new file mode 100644
index 000000000000..9c8a9fdaf58f
--- /dev/null
+++ b/app-accessibility/eflite/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>accessibility@gentoo.org</email>
+ <name>Gentoo Accessibility Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <use>
+ <flag name="16k_voice">Use a higher-quality voice.</flag>
+ </use>
+ <longdescription lang="en">
+ EFlite is a speech server for Emacspeak and other screen readers
+ that allows them to interface with Festival Lite, a free
+ text-to-speech engine developed at the CMU Speech Center as an
+ off-shoot of Festival.
+</longdescription>
+ <longdescription lang="ja">
+ EFliteはEmacspeakと他のスクリーン読取り装置のスピーチサーバ。この
+ サーバーで前のプログラムはFestival Lite(CMU Speech Centerで開発した
+ Festivalのようにスピーチにテキストを変わるエンジン。)と
+ インタフェスすることが出来る。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">eflite</remote-id>
+ </upstream>
+</pkgmetadata>